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PREFAȚĂ 

 

 

În peisajul actual al Industriei 4.0, eficiența proceselor de producție nu mai este doar un 

avantaj competitiv, ci o condiție a supraviețuirii pe piață. Digitalizarea fabricilor a transformat 

modul în care proiectăm, testăm și implementăm liniile de producție, iar software-ul Tecnomatix 

Process Simulate se află în avangarda acestei revoluții. 

Cartea de față - „Bazele simulării robotice și analiza cinematică în Process Simulate”, a fost 

elaborată din necesitatea de a oferi studenților, inginerilor și pasionaților de robotică un ghid 

structurat și aplicat într-un domeniu marcat adesea de o curbă de învățare abruptă. Simularea nu 

mai reprezintă doar o simplă vizualizare 3D; ea este instrumentul critic prin care putem anticipa 

coliziuni, optimiza timpii de ciclu și valida fluxuri tehnologice complexe înainte ca prima piesă de 

echipament să fie instalată fizic în fabrică. 

Deși documentația tehnică a software-ului este vastă, utilizatorul aflat la început de drum are 

nevoie de o metodologie clară de lucru. Lucrarea este concepută ca un parcurs logic, de la 

configurarea de bază a mediului de lucru și gestionarea datelor în structuri eMS, până la aspecte 

avansate de cinematică inversă și analiză de coliziuni. 

Această lucrare este dedicată atât studenților din facultățile de profil tehnic (Robotică, 

Mecatronică, Automatică), cât și inginerilor din industria auto și aerospațială care doresc să își 

aprofundeze cunoștințele în utilizarea soluțiilor Siemens. 

Digitalizarea înseamnă precizie. Sper ca acest manual să devină un instrument de lucru 

indispensabil pe biroul (sau ecranul) fiecărui viitor specialist în simulare, oferindu-i claritatea 

necesară pentru a transforma conceptele abstracte în celule robotice funcționale și sigure. 

 

 

Alina Bianca POP 
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1. SIMULAREA ROBOTICĂ CU PROCESS SIMULATE 

 

 

Această carte oferă o perspectivă academică și practică asupra utilizării software-ului Process 

Simulate on eMS (Engineering Manufacturing Services) pentru activități de simulare robotică. 

Obiectivul principal este de a familiariza utilizatorii cu fluxul de lucru esențial (Workflow) necesar 

pentru accesarea datelor, configurarea mediului de lucru și crearea structurii de operații (Operation 

Tree) la nivel înalt. Stăpânirea acestor concepte de bază este fundamentală pentru dezvoltarea 

ulterioară a simulărilor complexe. 

 

1.1. ACCESAREA DATELOR ÎN PROCESS SIMULATE 

 

Accesarea corectă a datelor reprezintă primul pas critic în orice sesiune de lucru Process Simulate. 

Acest capitol descrie metodele de pornire a aplicației și de deschidere a unui proiect existent dintr-o 

bază de date eMS (sau o bază de date similară). 

Obiectiv: Deschiderea unei sesiuni Process Simulate dintr-un studiu specific. 

Workflow: Pornirea Aplicației și Încărcarea Studiului 

1. Pornirea Aplicației: 

o Dacă pictograma Process Simulate este disponibilă pe desktop, executați un dublu-

clic. 

o În caz contrar, navigați la meniul Windows Start → Programs → Tecnomatix → 

Engineering Applications → Process Simulate. 

2. Autentificarea (Login): 

o În fereastra de autentificare, introduceți ID-ul de utilizator din baza de date eMS (ex: 

user1) în câmpul Login. 

o Introduceți parola în câmpul Password. 

o Apăsați OK. 
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3. Selectarea Proiectului: 

o Se va afișa fereastra Open Project (Lista de Proiecte). 

o Selectați proiectul dorit din lista Projects List (ex: Basics Project-userX). 

o Apăsați OK. 

 

4. Încărcarea Studiului: 

o În Process Simulate Navigation Tree, navigați la studiul dorit (ex: un RobcadStudy 

sau un LineSimulation Study). 

o Executați Click-dreapta pe studiu. 

o Selectați Load in Standard Mode pentru a încărca mediul de simulare. 

Workflow: Ieșirea din Aplicație 

1. Alegeți File → Exit din meniul principal pentru a închide sesiunea Process Simulate. 

Înțelegerea fluxului de lucru pentru deschiderea și închiderea sesiunilor asigură o gestionare eficientă 

a datelor proiectului, esențială pentru consistența și integritatea bazei de date eMS. 
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1.2.CONFIGURAREA OPȚIUNILOR DE BAZĂ 

 

Setările corecte ale opțiunilor de bază, în special cele legate de Graphic Viewer (Vizualizatorul 

Grafic) și System Root, sunt vitale pentru o experiență de utilizare optimă și pentru managementul 

eficient al datelor. System Root definește calea relativă către toate obiectele din bibliotecă, facilitând 

referențierea obiectelor între studiile din proiecte diferite. 

Obiectiv: Setarea opțiunilor de bază pentru Graphics Viewer (inclusiv culoarea de fundal) și a 

Process Simulate System Root. 

Workflow: Setarea Culorii de Fundal în Graphic Viewer 

1. Accesarea Opțiunilor: 

o În Process Simulate, alegeți Tools → Options. 

2. Navigarea la Setările de Aparență: 

o În dialogul Options, selectați fila (tab) Appearance. 

o În panoul din stânga, sub Graphic Viewer, selectați sub-secțiunea Background. 

 

3. Configurarea Fundalului: 

o În secțiunea Background din partea de jos, schimbați tipul de fundal. Din lista 

derulantă care afișează inițial Vertical (sau altă opțiune), selectați Solid. 

o Faceți clic pe selectorul de culoare și alegeți culoarea negru (black) pentru fundal. 

o Notă: Dacă se alege opțiunea Corners în loc de Vertical, se pot selecta patru culori 

diferite pentru un efect de gradient. Pentru acest exercițiu se utilizează Solid. 
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4. Aplicarea Schimbărilor: 

o Apăsați OK pentru a salva și aplica noile setări. 

 

Configurarea adecvată a mediului de lucru, cum ar fi setarea culorii de fundal la negru pentru un 

contrast optim, îmbunătățește lizibilitatea și precizia vizualizării grafice a simulărilor. 

 

1.3.CREAREA ARBORELUI DE OPERAȚII 

 

Arborele de Operații (Operation Tree) este structura ierarhică centrală în Process Simulate, definind 

secvența logică și organizarea activităților de producție (operațiile). Crearea unei structuri la nivel 

înalt ajută la împărțirea sarcinii generale de simulare în componente gestionabile, de obicei stații de 

lucru sau sub-procese majore. 

 

1.3.1. Crearea Rădăcinii Arborelui de Operații 

Obiectiv: Crearea nivelului superior (rădăcină) al arborelui de operații, numit Operation Tree, ca 

obiect de tip CompoundOperation. 

Workflow: Crearea Rădăcinii Operațiilor 
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1. Navigare și Check Out: 

o În Process Simulate Navigation Tree, extindeți proiectul curent (ex: Basics Project -

- user...). 

 

o Executați Click-dreapta pe colecția (folderul) Operation. 

o Alegeți Check Out și confirmați cu OK în dialogul Check Out. 

 

2. Crearea unui Obiect Nou (New): 

o Executați din nou Click-dreapta pe colecția (folderul) Operation. 
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o Alegeți New. 

3. Configurarea Noului Obiect: 

o În dialogul New, navigați și localizați tipul de obiect CompoundOperation. 

o Bifați caseta de selecție corespunzătoare sau introduceți 1 în câmpul Amount 

(Cantitate). 

o Derulați la dreapta și introduceți Operation Tree în câmpul Name (Nume). 

o Apăsați OK în dialogul New. 

 

4. Vizualizarea Rădăcinii Operațiilor: 

o Extindeți folderul Operation. 

o Executați Click-dreapta pe obiectul Operation Tree CompoundOperation (nu pe 

folder). 

o Alegeți Navigation Tree pentru a deschide o a doua fereastră Navigation Tree 

(Navigation Tree (2)) cu acest obiect ca rădăcină. 
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5. Adăugarea Stațiilor la Operația Rădăcină 

Obiectiv: Adăugarea a două stații de lucru ca sub-operații în cadrul rădăcinii Operation Tree. 

Workflow: Adăugarea Stațiilor 

1. Inițierea Creării (New): 

o În fereastra Navigation Tree (2) (al cărei obiect rădăcină este Operation Tree), 

executați Click-dreapta pe obiectul Operation Tree CompoundOperation. 

o Alegeți New. 

2. Configurarea Stațiilor: 

o În dialogul New, navigați și localizați din nou tipul de obiect CompoundOperation 

(acest tip este utilizat pentru a reprezenta și stațiile, care sunt operații compuse). 

o Introduceți 2 în câmpul Amount (Cantitate), deoarece dorim să creăm două stații. 

o Introduceți Station [1] în câmpul Name (Nume). 

▪ Notă: Utilizarea parantezelor drepte [ ] în nume ([1]) indică software-ului să 

incrementeze automat numărul (rezultând Station 1 și Station 2). 

o Apăsați OK în dialogul New. 
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3. Verificarea Structurii: 

o Extindeți structura sub Operation Tree în fereastra Navigation Tree (2) pentru a 

vizualiza cele două stații nou create (Station 1 și Station 2). 

 

Prin crearea ierarhiei de tip CompoundOperation, am stabilit cadrul operațional de bază, incluzând 

operația principală (Operation Tree) și sub-operațiile sale logice (Station 1, Station 2). Această 

structură este esențială pentru organizarea și secvențierea fluxurilor de lucru detaliate din cadrul 

fiecărei stații în etapele ulterioare ale simulării. 

 

1.3.2. Crearea Rădăcinii Arborelui de Resurse 

Similar cu Arborele de Operații, Arborele de Resurse (Resource Tree) este o structură ierarhică 

esențială. Obiectivul său este de a organiza toate resursele fizice și logice (cum ar fi stații, roboți, 

unelte, dispozitive sau operatori umani) care vor fi utilizate pentru a executa operațiile definite 

anterior. Crearea unei structuri de resurse la nivel înalt, care adesea oglindește structura operațiilor, 

este un pas fundamental în modelarea simulării. 

Obiectiv: Crearea nivelului superior (rădăcină) al arborelui de resurse, numit Resource Tree, ca obiect 

de tip CompoundResource. 

Workflow: Crearea Rădăcinii Resurselor 

1. Navigare și Check Out: 

o În fereastra principală Navigation Tree, extindeți proiectul curent (ex: Basics Project 

-- user...). 

o Executați Click-dreapta pe colecția (folderul) Resource. 

o Alegeți Check Out și confirmați cu OK în dialogul Check Out. 
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2. Crearea unui Obiect Nou (New): 

o Executați din nou Click-dreapta pe colecția (folderul) Resource. 

o Alegeți New. 

3. Configurarea Noului Obiect: 

o În dialogul New, navigați și localizați tipul de obiect CompoundResource. 

o Bifați caseta de selecție corespunzătoare sau introduceți 1 în câmpul Amount 

(Cantitate). 

o Derulați la dreapta și introduceți Resource Tree în câmpul Name (Nume). 

o Apăsați OK în dialogul New. 
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4. Vizualizarea Rădăcinii Resurselor: 

o Extindeți folderul Resource. 

o Executați Click-dreapta pe obiectul Resource Tree CompoundResource (nu pe 

folder). 

o Alegeți Navigation Tree pentru a deschide o nouă fereastră Navigation Tree (ex: 

Navigation Tree (3)) cu acest obiect ca rădăcină. 

 

 

Adăugarea Stațiilor la Resursa Rădăcină 

Obiectiv: Adăugarea a două stații de lucru (ca resurse compuse) în cadrul rădăcinii Resource Tree. 
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Workflow: Adăugarea Stațiilor de Resurse 

1. Inițierea Creării (New): 

o În fereastra Navigation Tree (3) (al cărei obiect rădăcină este Resource Tree), 

executați Click-dreapta pe obiectul Resource Tree CompoundResource. 

o Alegeți New. 

2. Configurarea Stațiilor: 

o În dialogul New, navigați și localizați din nou tipul de obiect CompoundResource. 

o Introduceți 2 în câmpul Amount (Cantitate). 

o Introduceți Station [1] în câmpul Name (Nume). 

▪ Notă: Utilizarea parantezelor drepte [ ] în nume ([1]) indică software-ului să 

incrementeze automat numărul (rezultând Station 1 și Station 2). 

o Apăsați OK în dialogul New. 

3. Verificarea Structurii: 

o Extindeți structura sub Resource Tree în fereastra Navigation Tree (3) pentru a 

vizualiza cele două stații de resurse nou create (Station 1 și Station 2). 

 

Prin finalizarea etapelor prezentate asupra Arborelui de Resurse (Resource Tree), am stabilit o 

structură ierarhică pentru gestionarea tuturor activelor fizice ale liniei de producție. Această structură 

este paralelă cu Arborele de Operații (Operation Tree) și este acum pregătită pentru etapa de asociere, 

în care legăm resursele de operațiile pe care le vor deservi. 

 

1.4.ASOCIEREA STRUCTURILOR 

 

Asocierea structurilor este procesul central în Process Simulate care dă viață modelului de simulare. 

Acesta implică crearea de legături logice între cele trei ierarhii fundamentale: Proces (Arborele de 

Operații - ce se face?), Produs (Arborele de Produse - pe ce se lucrează?) și Resursă (Arborele de 

Resurse - cine execută?). Acest model interconectat este adesea denumit PPR (Product-Process-
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Resource). Obiectivul acestui capitol este de a asocia structurile de operații, resurse și produse create 

anterior la nivelul stațiilor. 

Obiectiv: Asocierea stațiilor din Arborele de Resurse (Resource Tree) cu stațiile corespunzătoare din 

Arborele de Operații (Operation Tree). 

Workflow: Asocierea Resurselor la Operații (Drag and Drop) 

1. Pregătirea Vizualizării: 

o Asigurați-vă că atât fereastra Navigation Tree (2) - 'Operation tree' cât și fereastra 

Navigation Tree (3) - Resource tree sunt vizibile și aranjate una lângă alta. 

2. Asocierea Stației 1: 

o Din Navigation Tree (3) (Resurse), selectați obiectul Station 1 

(CompoundResource). 

o Executați Drag-and-drop (trageți și plasați) acest obiect peste Station 1 

(CompoundOperation) din Navigation Tree (2) (Operații). 

3. Asocierea Stației 2: 

o Repetați procesul: selectați Station 2 (CompoundResource) din Navigation Tree (3) 

și plasați-l peste Station 2 (CompoundOperation) din Navigation Tree (2). 

 

4. Verificarea Asocierii (Partea 1 - Operație): 

o În Navigation Tree (2), executați Click-dreapta pe Station 1 (CompoundOperation) 

și alegeți Properties. 
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o În dialogul Properties, selectați fila (tab) Resources pentru a vizualiza resursa 

(Station 1 CompoundResource) care tocmai a fost asociată. 

 

5. Verificarea Asocierii (Partea 2 - Resursă): 

o În Navigation Tree (3), selectați Station 1 (CompoundResource) și deschideți 

Properties. 

 

o Selectați fila (tab) Operations pentru a vizualiza cealaltă jumătate a relației 

bidirecționale care tocmai a fost creată. 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

20 

 

Asocierea Pieselor cu Operațiile (Part Assignment) 

Obiectiv: Asocierea reperelor (piese finale sau ansambluri) din Arborele de Produse (Product Tree) 

cu operațiile specifice (stațiile) care le vor procesa. 

Workflow: Asocierea Produselor la Operații 

1. Deschiderea Arborelui de Produse: 

o În fereastra principală Navigation Tree, extindeți colecția (folderul) Product. 

o Executați Click-dreapta pe obiectul rădăcină al produsului (ex: 'ps0003"Product Tree' 

CompoundPart) și alegeți Navigation Tree. Se va deschide o nouă fereastră (ex: 

Navigation Tree (4) sau (5)). 

 

2. Extinderea Structurii: 

o În noua fereastră a Arborelui de Produse, executați Click-dreapta pe rădăcina 

'ps0003"Product Tree' și alegeți Expand → Expand 3 Levels pentru a vizualiza toate 

sub-componentele. 
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3. Asocierea Pieselor (Drag and Drop): 

o Din fereastra Arborelui de Produse, selectați ansamblul 'ps0006"Purchased Assy 1' 

(CompoundPart) și plasați-l (drag-and-drop) peste Station 1 (CompoundOperation) 

din Navigation Tree (2). 

 

o Selectați piesa 'ps0007"Part C' și plasați-o, de asemenea, peste Station 1 

(CompoundOperation). 
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o Selectați piesa 'ps0008"Part D' și plasați-o peste Station 2 (CompoundOperation). 

 

4. Verificarea Asocierii: 

o Selectați Station 1 (CompoundOperation) în Navigation Tree (2) și deschideți 

fereastra Properties. 

o Selectați fila (tab) Products pentru a vizualiza lista pieselor și ansamblurilor care i-au 

fost alocate (ex: Purchased Assy 1 și Part C). 

5. Finalizare: 

o Închideți fereastra Properties și fereastra Navigation Tree a produsului. 
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Adăugarea Resurselor Specifice în Arborele de Resurse 

Obiectiv: Popularea stațiilor de resurse (Station 1, Station 2) cu resurse specifice (robot și operator 

uman) din biblioteca proiectului. 

Workflow: Adăugarea Resurselor din Bibliotecă 

1. Deschiderea Bibliotecii de Resurse: 

o În fereastra principală Navigation Tree, navigați la colecția (folderul) Libraries. 

o Executați Click-dreapta pe biblioteca ResourceLibrary și alegeți Navigation Tree. 

Se va deschide o fereastră a bibliotecii (ex: Navigation Tree (7)). 

2. Pregătirea Vizualizării: 

o Asigurați-vă că fereastra bibliotecii (Navigation Tree (7)) și fereastra Arborelui de 

Resurse (ex: Navigation Tree (8) - Resource tree) sunt vizibile. 

3. Alocarea Resurselor (Drag and Drop): 

o Din fereastra ResourceLibrary, selectați resursa robot (ex: fanuc_arcmate_120). 

o Plasați-o (drag-and-drop) peste Station 1 (CompoundResource) în fereastra Resource 

tree. 

o Din fereastra ResourceLibrary, selectați resursa operator uman (ex: Human (Jack)). 

o Plasați-o peste Station 2 (CompoundResource) în fereastra Resource tree. 

 

Prin finalizarea acestor asocieri, modelul de simulare este acum structural complet la nivel înalt. Am 

definit operațiile (Procesul), am alocat resursele (Resursa) necesare executării lor și am specificat 
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piesele (Produsul) care vor fi procesate. Această fundație PPR permite tranziția către definirea 

detaliată a traiectoriilor robotice, a simulărilor ergonomice și a secvențierii logice a evenimentelor. 

 

1.5. EXAMINAREA TIPURILOR DE OBIECTE 

 

Process Simulate utilizează o gamă vastă de tipuri de obiecte, fiecare reprezentând o entitate 

specifică în contextul de producție (Ex: CompoundOperation, CompoundResource, PartPrototype, 

etc.). Înțelegerea structurii, a colecțiilor și a simbolurilor asociate fiecărui tip de nod în Navigation 

Tree este crucială pentru navigarea și managementul eficient al proiectului. 

Obiectiv: Identificarea și examinarea diverselor tipuri de noduri de obiecte disponibile în structura 

proiectului. 

Workflow: Explorarea Tipurilor de Noduri 

1. Navigarea în Colecții: 

o Examinați colecțiile din vizualizatorul Navigation Tree (Arborele de Navigație), 

cum ar fi Product, Operation, Resource și Libraries. 

o Observați că fiecare nod este identificat printr-o pictogramă (icon) și, în cazul 

nodurilor de operații, printr-un custom caption care poate afișa informații 

suplimentare (de exemplu, timpul alocat pentru operație). 

2. Identificarea Tipurilor: 

o Extindeți ierarhiile din fiecare colecție (dacă nu sunt deja extinse). 

o Încercați să recunoașteți cât mai multe tipuri de noduri posibile (ex: nodurile pentru 

operații compuse, resurse compuse, părți, studii). 

o Notă: Utilizați o diagramă de referință (dacă este disponibilă) pentru a corela vizual 

simbolurile cu denumirile tipurilor de obiecte. 

Familiarizarea cu diferitele tipuri de obiecte și modul în care acestea sunt organizate în colecții 

(foldere) în Navigation Tree oferă o hartă mentală a întregului proiect, esențială pentru efectuarea 

operațiilor ulterioare de creare și modificare. 

 

1.6. RELAȚIA PROTOTIP ȘI INSTANȚĂ 

 

Relația dintre prototip și instanță este un concept fundamental în Process Simulate, asigurând coerența 

și reutilizarea datelor. Un Prototype (Prototip) este definiția originală a unui obiect (o piesă, o resursă, 

o unealtă) și este stocat în Libraries (Biblioteci). O Instance (Instanță) este o referință (o utilizare) a 

acelui prototip, plasată într-un arbore de lucru (ex: Product Tree sau Resource Tree). Instanțele 

moștenesc majoritatea atributelor de la prototip, dar pot avea proprietăți specifice contextului lor de 

utilizare (ex: poziție, orientare). 
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1.6.1. Examinarea Bibliotecii de Piese 

Obiectiv: Deschiderea și examinarea proprietăților prototipurilor de piese stocate în bibliotecă. 

Workflow: Accesarea și Vizualizarea Prototipurilor de Piese 

1. Închiderea Ferestrelor: 

o Închideți toate ferestrele Properties și Navigation Tree deschise anterior, păstrând 

doar Navigation Tree principală. 

2. Deschiderea Bibliotecii de Piese: 

o În Navigation Tree principală, navigați la colecția (folderul) Libraries. 

o Executați Click-dreapta pe PartLibrary. 

o Alegeți Navigation Tree. Se va deschide un vizualizator nou numit, de obicei, 

Navigation Tree (2) - PartLibrary. 

 

3. Vizualizarea Proprietăților Prototipului: 

o În Navigation Tree (2), extindeți arborele pentru a vedea obiectele de tip 

PartPrototype (ex: 'ps0008"Part D'). 
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o Executați Click-dreapta pe unul dintre obiectele PartPrototype și alegeți Properties. 

4. Examinarea Tipului de Obiect: 

o În dialogul Properties deschis, asigurați-vă că este selectată fila General. 

o Acordați atenție câmpului Type, care va indica PartPrototype. 

 

5. Blocarea Fereastrei Properties (Opțional): 

o Pentru a menține fereastra Properties vizibilă și asociată acestui obiect, faceți clic pe 

pictograma Lock displayed information (de obicei, o pictogramă cu un lacăt sau un 

disc). 
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Examinarea Instanțelor de Piese în Arborele de Produs 

Obiectiv: Vizualizarea relației dintre prototipul din bibliotecă și instanța sa utilizată în Product Tree 

și examinarea proprietăților instanței. 

Workflow: Compararea Prototipului cu Instanța 

1. Deschiderea Arborelui de Produs: 

o În Navigation Tree principală, executați Click-dreapta pe rădăcina Product Tree din 

colecția Product. 

 

o Alegeți Navigation Tree. Se va deschide o nouă fereastră (ex: Navigation Tree (3) - 

'ps0003"Product Tree'). 

 

2. Utilizarea Lupei pentru Relație: 

o Executați Drag-and-drop (trageți și plasați) al unui PartPrototype (ex: 'ps0008"Part 

D') din fereastra Navigation Tree (2) - PartLibrary pe pictograma lupă (magnifying 

glass) aflată pe fereastra Navigation Tree (3) - Product Tree. 

o Rezultat: Arborele de Produs se va extinde automat, iar instanțele corespunzătoare ale 

prototipului în cauză (ex: 'ps0008"Part D') din arborele de produs vor fi evidențiate. 
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3. Vizualizarea Proprietăților Instanței: 

o Executați Click-dreapta pe obiectul Part evidențiat în Product Tree (Navigation 

Tree (3)) și alegeți Properties. 

o În dialogul Properties (ex: Properties (2)), selectați fila General. 

o Observați câmpul Type. Acesta va arăta PartPrototype urmat de un mic (i) (ex: 

PartPrototype(i)), indicând faptul că este o Instanță a prototipului. 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

29 

 

4. Finalizarea Activității: 

o Închideți ferestrele de Properties și vizualizatoarele Navigation Tree (Navigation 

Tree (2) și Navigation Tree (3)) care au fost deschise pentru această activitate. 

În Process Simulate, prototipurile de obiecte din Libraries servesc ca matrițe reutilizabile, iar 

instanțele din arborii de lucru (Product Tree, Resource Tree) sunt reprezentări utilizate în simulare. 

Această arhitectură de moștenire (instanțele moștenesc atribute de la prototipuri) este esențială pentru 

a menține eficiența datelor și pentru a permite modificări centralizate. 

 

1.6.2. Examinarea Bibliotecii de Resurse 

Principiul Prototip-Instanță se aplică și resurselor (roboți, unelte, operatori umani), permițând 

modelarea eficientă a celulelor de producție. Prototipurile de resurse sunt stocate în ResourceLibrary 

și oferă baza (geometrie, cinematiă) pentru toate utilizările ulterioare, care sunt reprezentate ca 

Instanțe în Arborele de Resurse al Proiectului. 

Obiectiv: Deschiderea și examinarea proprietăților prototipurilor de resurse (ex: robot, operator 

uman) din bibliotecă. 

Workflow: Accesarea și Vizualizarea Prototipurilor de Resurse 

1. Închiderea Fereastrelor: 

o Închideți toate ferestrele Properties și Navigation Tree deschise anterior, păstrând 

doar Navigation Tree principală. 

2. Deschiderea Bibliotecii de Resurse: 

o În Navigation Tree, navigați la colecția (folderul) Libraries. 

o Executați Click-dreapta pe ResourceLibrary. 

o Alegeți Navigation Tree. Se va deschide un vizualizator nou (ex: Navigation Tree 

(2)). 
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3. Extinderea și Selectarea: 

o În fereastra nou deschisă, extindeți arborele bibliotecii. 

o Selectați un prototip de resursă (ex: fanuc_arcmate_120). 

4. Vizualizarea Proprietăților Prototipului: 

o Executați Click-dreapta pe prototipul de resursă și alegeți Properties. 

o În dialogul Properties (fila General), acordați atenție câmpului Type, care va afișa 

tipul specific de prototip (ex: ToolPrototype sau CompoundResource pentru un 

robot/om). 

 

5. Închiderea Fereastrei: 

o Închideți dialogul Properties. 

 

Examinarea Instanțelor în Arborele de Resurse 

Obiectiv: Observarea modului în care o instanță de resursă este referențiată în Arborele de Resurse. 

Workflow: Explorarea Relației Instanță-Prototip 

1. Navigarea la Resurse: 

o În Navigation Tree principală, navigați la colecția (folderul) Resource. 
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o Executați Click-dreapta pe rădăcina Resource Tree și deschideți-o într-un 

vizualizator Navigation Tree separat (ex: Navigation Tree (3)). 

 

2. Identificarea Instanțelor: 

o Extindeți Resource Tree până când vedeți instanțele resurselor adăugate anterior (ex: 

robotul fanuc_arcmate_120 sub Station 1). 

3. Verificarea Relației: 

o Executați Drag-and-drop al unei Instanțe de resursă din Arborele de Resurse pe 

pictograma lupă (magnifying glass) a ferestrei bibliotecii de resurse. Această acțiune 

va evidenția prototipul corespunzător în bibliotecă, consolidând înțelegerea relației 

Instanță-Prototip. 

4. Închiderea Fereastrelor: 

o Închideți ferestrele Navigation Tree (2) și Navigation Tree (3) deschise pentru această 

activitate. 

Notă: Biblioteca de Operații (Operation Library) nu respectă relația Prototip-Instanță în același 

mod; fiecare operație este considerată individuală. Biblioteca de Operații servește ca un depozit de 

operații standard sau puncte de pornire. 

Modelul Prototip-Instanță aplicat resurselor asigură că toate atributele de bază (geometrie, cinematiă) 

sunt definite o singură dată la nivel de prototip în bibliotecă, în timp ce instanțele din Arborele de 
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Resurse pot fi poziționate și configurate individual pentru a se potrivi cerințelor specifice ale fiecărei 

stații de lucru. 

 

1.7.CREAREA UNUI STUDIU 

 

Un Study (Studiu) este containerul de bază în Process Simulate care reunește o selecție de operații, 

resurse și piese necesare pentru o simulare specifică. Crearea unui studiu necesită pregătirea mediului 

de lucru (Working Folder) și definirea noului container de studiu. 

 

1.7.1. Setarea Working Folder 

Obiectiv: Setarea folderului de lucru (zona temporară de stocare, scratch area) a software-ului. 

Workflow: Configurare și Alocare 

1. Închiderea Fereastrelor: 

o Închideți toate vizualizările Navigation Tree suplimentare, păstrând doar pe cea 

principală. 

2. Navigare la Working Folders: 

o În Navigation Tree, navigați la colecția (folderul) Working Folders. 

3. Check Out Folder Personalizat: 

o Localizați folderul de lucru alocat (ex: User1 Working Folder). 

o Executați Click-dreapta pe folderul alocat și alegeți Check Out. 

o Apăsați OK în dialogul de confirmare. 

4. Setarea ca Working Folder: 

o Alegeți File → Project Management → Set as Working Folder din meniul 

principal. 

o Notă: După setare, numele folderului de lucru în Navigation Tree va fi afișat în format 

aldin (bold). 
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Working Folder este esențial, acționând ca o zonă temporară unde Process Simulate stochează 

fișierele de lucru și de salvare în timpul sesiunii. Setarea acestuia este un pas de pregătire necesar 

înainte de a crea orice entitate nouă, cum ar fi un studiu. 

 

1.7.2. Crearea unui nou Studiu Robotic 

După pregătirea folderului de lucru, pasul următor este crearea unui nou studiu (de tip Robcad 

Study), urmată de adăugarea structurii de operații la acesta și, în final, încărcarea studiului în mediul 

de simulare. 

Obiectiv: Crearea unui container de studiu nou în folderul alocat. 

Workflow: Definirea Studiului (Robcad Study) 

1. Navigare și Check Out (Folder Studiu): 

o În Navigation Tree, extindeți colecția (folderul) Studies. 

o Localizați folderul de studiu alocat (ex: Line1). 

o Executați Click-dreapta pe folderul alocat și alegeți Check Out. 

o Atenție: Bifați caseta with Hierarchy în dialogul de Check Out (aceasta este una 

dintre rarele cazuri în care este necesar). 

o Apăsați OK și extindeți folderul de studiu. 
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2. Crearea Studiului: 

o Executați Click-dreapta pe folderul de studiu alocat (ex: Line1 StudyFolder). 

o Alegeți New. 

o În dialogul New, bifați caseta pentru Robcad Study. 

o Schimbați Name-ul (Numele) în Study. 

o Apăsați OK. 
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Popularea și Încărcarea Studiului 

Obiectiv: Adăugarea structurii de operații la studiu și deschiderea acestuia în Graphic Viewer. 

Workflow: Asamblarea și Deschiderea Studiului 

1. Asocierea Arborelui de Operații: 

o Localizați Operation Tree CompoundOperation în colecția Operation. 

o Executați Drag-and-drop (trageți și plasați) Operation Tree CompoundOperation 

peste noul obiect Study RobcadStudy creat în folderul de studii. 

o Notă: În mod normal, s-ar adăuga doar o porțiune relevantă a Arborelui de Operații, 

nu întreaga structură. 
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2. Încărcarea Studiului: 

o Executați Click-dreapta pe obiectul Study RobcadStudy. 

o Alegeți Load in Standard Mode. 
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3. Vizualizare 3D: 

o În fereastra Graphic Viewer (Vizualizatorul Grafic) care se deschide: 

▪ Executați Click-dreapta și alegeți Display All. 

 

▪ Executați Click-dreapta și alegeți Zoom to Fit. 
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o Acum ar trebui să vedeți reprezentările 3D ale resurselor asociate studiului (robotul și 

operatorul uman, dacă acestea aveau deja date 3D atașate prototipurilor lor). 

4. Finalizarea Activității: 

o Închideți toate vizualizatoarele Navigation Tree deschise, cu excepția celui principal. 

Studiul este acum creat și încărcat, aducând în mediul 3D toate operațiile, resursele și piesele (dacă 

acestea au geometrie) definite și asociate. Această etapă marchează finalizarea configurării inițiale a 

mediului și pregătește terenul pentru definirea detaliată a traiectoriilor, a logicii de simulare și a 

analizei rezultatelor. 

 

1.8. PREZENTARE GENERALĂ A VIZUALIZATORULUI PROCESS SIMULATE 

 

După încărcarea unui studiu, mediul de lucru Process Simulate devine populat cu vizualizatoare cheie 

precum Object Tree, Operation Tree și Relations Viewer. Aceste instrumente sunt esențiale pentru 

navigarea, examinarea și verificarea relațiilor dintre diferitele entități (piese, resurse, operații) incluse 

în simulare. 

 

1.8.1. Explorarea Studiului Încărcat 

Obiectiv: Navigarea prin structurile de date din Object Tree și Operation Tree și examinarea 

relațiilor din Relations Viewer. 

Workflow: Navigarea în Arbori 

1. Localizarea Object Tree: 

o Localizați vizualizatorul Object Tree (Arborele de Obiecte) și asigurați-vă că este 

selectată fila (tab) corespunzătoare. 
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2. Extinderea Structurii: 

o În Object Tree, executați Click-dreapta pe folderul Parts și alegeți Expand 2 Levels. 

Se vor vedea piesele și sub-ansamblurile alocate studiului. 

 

o Executați Click-dreapta pe folderul Resources și alegeți Expand 3 Levels. Se vor 

vedea stațiile și resursele specifice (ex: robot, operator uman). 

 

3. Extinderea Operațiilor: 

o Localizați vizualizatorul Operation Tree (Arborele de Operații). 

o Faceți clic pe simbolul + de lângă Operation Tree CompoundOperation pentru a 

extinde și a vedea Station 1 și Station 2. 
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Workflow: Utilizarea Relations Viewer și Properties 

1. Deschiderea Relations Viewer: 

o Dacă nu este vizibil, alegeți View → Open with → Relations Viewer din meniul 

principal. 

 

2. Examinarea Relației Resursă-Operație (Nivel Rădăcină): 

o În Operation Tree, selectați Operation Tree Compound Operation. 

o În Relations Viewer, observați relația cu Resource Tree Compound Resource, 

confirmând legătura bidirecțională realizată anterior. 
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3. Examinarea Relațiilor la Nivel de Stație (PPR): 

o În Operation Tree, selectați Station 1 CompoundOperation. 

o În Relations Viewer, observați entitățile de Products (ex: Purchased Assy 1, Part C) 

și Resources (ex: Station 1 Resource) asociate acestei operații. 

 

o Repetați procesul pentru Station 2 CompoundOperation pentru a vizualiza piesa Part 

D. 
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4. Vizualizarea Proprietăților: 

o În Operation Tree, selectați Operation Tree și alegeți View → Open with → 

Properties (sau apăsați Alt+Enter). 

o Examinați atributele (Attributes), costurile (Cost & Responsibility) și relațiile (filele 

Products, Resources) pentru obiectul selectat. 

o Selectați alte obiecte în Operation Tree pentru a vedea atributele lor. 

 

 

5. Închiderea: 

o Închideți vizualizatorul Properties. 

Vizualizatoarele Object Tree, Operation Tree și Relations Viewer funcționează ca un sistem de 

diagnosticare a datelor. Acestea permit utilizatorului să verifice rapid structura datelor, să confirme 



Bazele simulării robotice și analiza cinematică în Process Simulate 

43 

 

asocierile PPR (Produs-Proces-Resursă) și să acceseze atributele detaliate ale oricărui obiect de bază 

din baza de date. 

 

1.9. GESTIONAREA LAYOUT-ULUI FERESTRELOR 

 

Process Simulate permite utilizatorilor să personalizeze și să salveze aranjamentul ferestrelor 

(viewers) și al barelor de instrumente (Layout) pentru a optimiza eficiența în funcție de sarcină (ex: 

un layout pentru Path Editor, altul pentru Collision Viewer). Această flexibilitate îmbunătățește 

productivitatea prin acces rapid la informațiile necesare. 

 

12.1.Docking și Floating Viewers 

Obiectiv: Modificarea modului de afișare al vizualizatoarelor între stările Docked (andocat), 

Floating (plutitor), Tabbed (cu file) și Auto Hide (ascundere automată). 

Workflow: Modificarea Poziției Ferestrelor 

1. Identificarea Vizualizatoarelor: 

o Localizați vizualizatoarele deschise (ex: Navigation Tree, Object Tree, Operation 

Tree, Relations Viewer, Sequence Editor etc.). 

 

2. Trecerea la Floating (Plutitor): 

o În colțul din dreapta sus al zonei de titlu a vizualizatorului (ex: Operation Tree), faceți 

clic pe pictograma Window Position (poziția ferestrei) și alegeți Floating. Fereastra 

devine mobilă. 
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3. Trecerea la Docking (Andocare): 

o Dublu-clic pe zona de titlu a vizualizatorului plutitor pentru a-l andoca automat înapoi 

la poziția sa inițială. 

 

4. Andocare în Poziție Nouă: 

o Trecere la Floating (sau desprindeți-l din poziția andocată actuală, trăgând de bara de 

titlu). 

o Începeți să trageți vizualizatorul peste o altă fereastră andocată (ex: Navigation Tree). 

o Va apărea un indicator de direcție (o săgeată în patru direcții). Trageți vizualizatorul 

peste una dintre săgeți pentru a-l andoca pe marginea respectivă (dreapta, stânga, sus, 

jos) a ferestrei vizate. 
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5. Andocare ca Tab (Filă): 

o Trageți vizualizatorul (ex: Operation Tree) peste o altă fereastră (ex: Object Tree). 

o Plasați-l pe pictograma din centrul indicatorului de direcție (cea care reprezintă 

suprapunerea). 

o Rezultat: Operation Tree va fi andocată ca o filă în grupul de ferestre care conține și 

Object Tree. 
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6. Trecerea la Auto Hide (Ascundere Automată): 

o În colțul din dreapta sus al vizualizatorului, faceți clic pe pictograma Window 

Position și alegeți Auto Hide (sau faceți clic pe pictograma Pin - boldiță). 

o Rezultat: Fereastra se va micșora într-o bară laterală (de obicei în stânga sau jos) și 

se va extinde automat doar când treceți cu mouse-ul peste ea. 
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1.9.1. Salvarea unui Layout de Fereastră 

Obiectiv: Crearea și salvarea unor aranjamente personalizate de ferestre pentru reutilizare. 

Workflow: Salvarea unui Layout Nou 

1. Configurarea Layout-ului: 

o Aranjați, poziționați și redimensionați toate vizualizatoarele dorite conform 

preferințelor (ex: Operation Tree sub Navigation Tree, Relations Viewer separat). 
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2. Accesarea Layout Manager: 

o Din bara de instrumente Process Simulate, faceți clic pe Layout Manager (sau View 

→ Layout Manager). 

 

3. Crearea Layout-ului: 

o În dialogul Layout List, faceți clic pe New. 

 

o În dialogul New Layout, alegeți Use Current pentru ambele opțiuni (Toolbars and 

Top-Level Menus și Context Menus). 

 

o Faceți clic pe OK. 

4. Denumirea Layout-ului: 

o În dialogul Layout List, introduceți un nume nou pentru layout-ul salvat (ex: 

Layout1_USERID_UNDEFINED). 

o Notă: Dacă numele nou nu este evidențiat, selectați-l, apăsați F2 și tastați numele. 
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o Faceți clic pe Close. 

5. Crearea unui Al Doilea Layout: 

o Schimbați aranjamentul ferestrelor mutând câteva vizualizatoare. 

o Repetați pașii 2-4 pentru a salva un al doilea layout (ex: 

Layout2_USERID_UNDEFINED). 

 

 

1.9.2. Utilizarea unui Layout de Fereastră 

Obiectiv: Comutarea rapidă între layout-urile de ferestre salvate. 

Workflow: Aplicarea Layout-urilor 

1. Comutarea Layout-ului Personalizat: 

o Din bara de instrumente Process Simulate, utilizați lista derulantă Layout (lângă 

pictograma Layout Manager). 

o Selectați Layout1_USERID_UNDEFINED. 
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o Rezultat: Aranjamentul ferestrelor se va schimba imediat, aplicând poziția și 

dimensiunea salvate. 

2. Aplicarea Layout-ului Standard: 

o Din aceeași listă derulantă, selectați Standard Layout. 

o Apăsați Apply (sau selectați-l direct dacă este configurat astfel). 

 

o Rezultat: Fereastra revine la aranjamentul implicit al software-ului. 
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Gestionarea layout-ului ferestrelor (Layout Management) este o tehnică avansată de optimizare a 

fluxului de lucru. Prin salvarea și aplicarea rapidă a layout-urilor personalizate, utilizatorii pot 

reconfigura mediul de lucru pentru a se potrivi cerințelor specifice ale sarcinilor de simulare, de la 

editarea de cale la vizualizarea coliziunilor. 
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 2. MEDIUL PROCESS SIMULATE ON EMS ȘI LUCRUL CU

VIZUALIZATOARE 

Acest capitol se adresează utilizatorilor care operează Process Simulate în cadrul mediului eMS 

(Enterprise Manufacturing Solutions) sau Teamcenter. Accentul cade pe navigarea și înțelegerea 

structurilor de date complexe specifice producției de automobile, unde sunt implicate multiple nivele 

de piese (Product), operații (Operation) și resurse (Resource). Vizualizatoarele (Viewers) reprezintă 

interfața principală de examinare a acestor structuri complexe și a relațiilor PPR (Product-Process-

Resource) în cadrul unui studiu. 

2.1. LUCRUL CU VIZUALIZATOARE 

2.1.1. Automotive - Obținerea unei Vederi Generale a Obiectelor din Object Tree 

Obiectiv: Explorarea nodurilor și structurii datelor complexe (Product, Resource) în vizualizatoarele 

Operation Tree, Logical Collections Tree și Object Tree dintr-un proiect specific. 

Workflow: Pregătirea Mediului de Lucru eMS 

1. Verificarea Dispozitivelor:

o Înainte de a lansa Process Simulate, asigurați-vă că dispozitivele opționale (ex: Space

Mouse) sunt conectate și că driverele necesare sunt încărcate.

2. Lansarea Aplicației și Logarea:

o Lansați Process Simulate (ex: dublu-clic pe pictograma de pe desktop).

o În dialogul de logare, introduceți eMS database user ID (ex: user1). Nu este necesară

introducerea unei parole, cu excepția cazului în care sistemul o cere.

o Faceți clic pe OK.
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3. Închiderea Proiectului Curent: 

o Dacă un proiect este deja deschis, alegeți File → Close Project. 

 

o Dacă apare avertismentul "You are about to close the project. Do you wish to 

continue?", selectați Yes. 
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o Dacă apare solicitarea "Do you wish to update eMServer?", selectați No pentru a evita 

modificările neintenționate. 

 

4. Deschiderea Proiectului Automotive Dorit: 

o Alegeți File → Open Project. 

 

o În dialogul Open Project, selectați proiectul de referință (ex: Robotics Example) și 

faceți clic pe OK. 
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o Notă: Acest proiect încarcă o zonă preexistentă a arborelui de operații ce conține date 

3D (piese și resurse asociate cu COJTs - Coordinated Joint Trajectories). 

5. Extinderea Arborelui de Navigație: 

o În vizualizatorul Navigation Tree, extindeți arborele principal al proiectului Robotics 

Example pentru a vedea colecțiile de bază (Resource, Operations, Product, 

Working Folders, Libraries, Studies). 

 

Workflow: Setarea Working Folder 

1. Navigare: 

o În Navigation Tree, navigați la colecția (folderul) Working Folders. 

 

2. Check Out Folder Personalizat: 

o Localizați folderul de lucru alocat (ex: User1 Working Folder pentru user1). 
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o Executați Click-dreapta pe folder și alegeți Check Out. 

o Faceți clic pe OK în dialogul de confirmare. 

 

3. Setarea ca Working Folder: 

o Alegeți File → Project Management → Set as Working Folder din meniul 

principal. 

o Notă: Textul folderului de lucru în Navigation Tree va fi afișat acum în format aldin 

(bold). 
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Workflow: Încărcarea Studiului (Load Study) 

1. Navigare la Studii: 

o În Navigation Tree, navigați la colecția (folderul) Studies. 

 

o Navigați la folderul de studiu alocat (ex: Line10). 

 

2. Check Out Studiu: 

o Executați Click-dreapta pe studiul specific (ex: Robotics Example study sau OP10... 

study) și alegeți Check Out. 

o Faceți clic pe OK. 
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3. Încărcarea Studiului: 

o Executați din nou Click-dreapta pe studiul selectat și alegeți Load in Standard 

Mode. 

o Așteptați câteva secunde pentru încărcarea datelor 3D în Graphic Viewer. 

 

Workflow: Explorarea Structurilor din Viewers 

1. Object Tree (Parts): 
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o Faceți clic pe fila Object Tree. 

o Executați Click-dreapta pe folderul Parts și alegeți Expand 2 Levels pentru a 

vizualiza piesele asociate studiului (ex: LandingGear_textured, tire_mount, etc.). 

 

2. Object Tree (Resurse): 

o În Object Tree, executați Click-dreapta pe folderul Resources și alegeți Expand 1 

Level (sau Expand 2 Levels dacă este necesar) pentru a vizualiza structura de resurse 

asociate (ex: OP10 user10). 

 

3. Operation Tree: 

o Selectați vizualizatorul Operation Tree. 
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o Faceți clic pe simbolul + de lângă procesul de nivel superior (ex: OP10 user10 process) 

pentru a extinde și a vedea sub-operațiile secvențiale (ex: 10 OPERATOR LOAD 

ASM, 20 CLAMP AND ROBOTIC WELD, 30 ROBOTIC UNLOAD, etc.). 

 

În urma acestei activități, mediul Process Simulate este încărcat cu un studiu complex din mediul 

eMS. Prin utilizarea Object Tree și Operation Tree, utilizatorul poate naviga rapid și eficient prin 

mii de entități, obținând o imagine clară a structurii ierarhice a pieselor, resurselor și fluxului logic de 

operații. Această capacitate de a vizualiza și manipula datele structurate este piatra de temelie pentru 

toate activitățile de simulare și validare. 

 

2.1.2. Airplane - Obținerea unei Vederi Generale a Obiectelor din Object Tree 

Obiectiv: Explorarea structurilor de date (Product, Resource, Operation) dintr-un proiect complex 

specific industriei aeronautice, utilizând vizualizatoarele Operation Tree, Logical Collections Tree 

și Object Tree. 

În industria aeronautică, simulările implică adesea asambluri masive și linii de producție complexe 

(Ex: Workcenters). Această activitate demonstrează cum se navighează și se înțelege structura unui 

astfel de proiect (Airplane Project), asigurând că toate resursele, piesele și operațiile sunt încărcate și 

vizualizate corect, inclusiv asocierea datelor 3D și a COJTs. 

Workflow: Pregătirea și Încărcarea Proiectului Aeronautic 

1. Verificarea Dispozitivelor: 

o Asigurați-vă că dispozitivele opționale (ex: Space Mouse) sunt pregătite, cu driverul 

încărcat (indicat de un inel albastru în jurul manipulatorului, dacă este cazul). 

2. Lansarea Aplicației și Logarea: 

o Lansați Process Simulate și, dacă nu sunteți deja logat, introduceți eMS database user 

ID (ex: user1) în câmpul Login. 
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o Faceți clic pe OK. 

3. Închiderea Proiectului Curent: 

o Alegeți File → Close Project. 

o Confirmați cu Yes la solicitarea de închidere a proiectului. 

o Selectați No la solicitarea de actualizare a eMServer. 

 

4. Deschiderea Proiectului Dorit: 

o Alegeți File → Open Project. 

 

o În dialogul Open Project, selectați Airplane Project (ex: Airplane Project 082015) 

și faceți clic pe OK. 
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o În Navigation Tree, extindeți arborele principal al proiectului (Airplane Project) 

pentru a vedea colecțiile de bază. 

 

5. Setarea Working Folder: 

o Navigați la colecția Working Folders. 
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o Executați Click-dreapta pe folderul de lucru alocat utilizatorului (ex: User1 Working 

Folder) și alegeți Check Out, apoi OK. 

 

o Alegeți File → Project Management → Set as Working Folder. (Numele folderului 

va apărea bold.) 

 

6. Localizarea și Încărcarea Studiului: 

o În Navigation Tree, navigați la colecția Studies și apoi în folderul de studiu alocat 

(ex: Line10). 

o Localizați studiul de lucru (ex: Workcenter 50 Study). 
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o Executați Click-dreapta pe studiu și alegeți Check Out, apoi OK. 

o Executați Click-dreapta pe studiu și alegeți Load in Standard Mode. 

o Așteptați finalizarea încărcării datelor 3D în Graphic Viewer. 

 

Workflow: Explorarea Structurilor din Viewers 

1. Examinarea Arborelui de Produs (Parts): 

o Faceți clic pe fila Object Tree. 

o Executați Click-dreapta pe folderul Parts și alegeți Expand 2 Levels (sau Expand 3 

Levels) pentru a vizualiza structura complexă a pieselor din ansamblul aeronavei (ex: 
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Workcenter 50 Mfg Assy și sub-ansamblurile sale: Tail Assy, cockpit Assy, Landing 

Gear Assy, etc.). 

 

2. Examinarea Arborelui de Resurse (Resources): 

o În Object Tree, executați Click-dreapta pe folderul Resources. 

o Alegeți Expand 2 Levels pentru a vizualiza stația de lucru (Workcenter 50) și 

componentele sale structurale și de echipament (ex: Holding Fixture, desk_contents, 

Platform, toolcrib, tire area). 

 

3. Examinarea Arborelui de Operații (Operations): 

o Selectați vizualizatorul Operation Tree. 

o Faceți clic pe simbolul + de lângă procesul de nivel superior (ex: Workcenter 50 

Process) pentru a-l extinde și a vizualiza secvența operațiilor. 
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Prin încărcarea și explorarea proiectului aeronautic, s-a demonstrat capacitatea Process Simulate de 

a gestiona și vizualiza structuri ierarhice de date de complexitate ridicată. Abilitatea de a naviga rapid 

prin Object Tree și Operation Tree este esențială pentru a localiza, a înțelege și a manipula entitățile 

cheie într-un context industrial extins. 

 

2.1.3. Structuri de date - Obținerea unei Vederi Generale a Obiectelor din Object Tree 

Obiectiv: Explorarea structurilor de date (Product, Resource, Operation) dintr-un proiect de tip 

structural, punând accentul pe navigația prin asamblări de infrastructură (ex: camere, pereți, utilități) 

utilizând vizualizatoarele Operation Tree, Logical Collections Tree și Object Tree. 

Proiectele de tip Structure sunt folosite în Process Simulate pentru a modela spațiile fizice, clădirile 

și infrastructura de producție. Acestea diferă de proiectele de produs/robot, deoarece structurile de 

produs includ adesea elemente staționare mari (pereți, pardoseli, sisteme HVAC). Această activitate 

demonstrează cum se încarcă și se examinează un astfel de proiect (Structure Project) în mediul eMS. 

Workflow: Pregătirea și Încărcarea Proiectului Structural 

1. Verificarea Dispozitivelor: 

o Asigurați-vă că dispozitivele opționale (ex: Space Mouse) sunt pregătite, cu driverul 

încărcat. 

2. Lansarea Aplicației și Logarea: 

o Lansați Process Simulate și logați-vă cu eMS database user ID (ex: user1). 

o Faceți clic pe OK. 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

67 

 

3. Închiderea Proiectului Curent: 

o Alegeți File → Close Project. 

o Confirmați cu Yes la solicitarea de închidere a proiectului. 

o Selectați No la solicitarea de actualizare a eMServer. 

4. Deschiderea Proiectului Structural Dorit: 

o Alegeți File → Open Project. 

o În dialogul Open Project, selectați Structure Project (ex: Structure Project 082015) 

și faceți clic pe OK. 

o În Navigation Tree, extindeți arborele principal al proiectului. 

 

5. Setarea Working Folder: 

o Navigați la colecția Working Folders. 

o Executați Click-dreapta pe folderul de lucru alocat utilizatorului (ex: User1 Working 

Folder) și alegeți Check Out, apoi OK. 

o Alegeți File → Project Management → Set as Working Folder. (Numele folderului 

va apărea bold.) 
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6. Localizarea și Încărcarea Studiului: 

o În Navigation Tree, navigați la colecția Studies și apoi în folderul de studiu alocat 

(ex: Line10). 

 

o Localizați studiul de lucru (ex: Structure Study). 

o Executați Click-dreapta pe studiu și alegeți Check Out, apoi OK. 

o Executați Click-dreapta pe studiu și alegeți Load in Standard Mode. 

o Așteptați finalizarea încărcării datelor 3D. 
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Workflow: Explorarea Structurilor din Viewers 

1. Examinarea Arborelui de Produs (Parts - Infrastructura): 

o Faceți clic pe fila Object Tree. 

o Executați Click-dreapta pe folderul Parts și alegeți Expand 2 Levels. 
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o Observați structura tipică a unei construcții (ex: Room 100) cu sub-componentele sale: 

floors (pardoseli), walls (pereți), hvac (sistem HVAC), columns (stâlpi), etc. Această 

structură extinsă reprezintă geometria de fundal pe care se va desfășura simularea. 

2. Examinarea Arborelui de Resurse (Resources): 

o În Object Tree, executați Click-dreapta pe folderul Resources. 

o Alegeți Expand 2 Levels pentru a vizualiza resursele (echipamentele și stațiile de 

lucru) asociate structurii (ex: Line10 și Unit 10 Workcenter). 

 

3. Examinarea Arborelui de Operații (Operations): 

o Selectați vizualizatorul Operation Tree. 

o Faceți clic pe simbolul + de lângă operația de nivel superior (ex: Unit 10) și continuați 

să extindeți nodurile. 
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o Observație: Operațiile dintr-un proiect structural pot include etape de construcție sau 

instalare de utilități (ex: extindeți Room 100 pentru a vedea Foundation Bill, HVAC 

Bill, Electrical Bill). 

Proiectele de tip Structure oferă un cadru complet pentru simularea layout-ului fizic al unei fabrici, 

combinând geometria de infrastructură (modelată ca Parts) cu resursele și operațiile. Prin parcurgerea 

acestor pași, utilizatorul a dobândit competența necesară pentru a încărca și naviga eficient prin 

structuri de date specifice, esențială pentru orice analiză sau modificare ulterioară în Process 

Simulate. 

 

2.1.4. Bazele Object Tree și Grupuri 

Obiectiv: Înțelegerea ierarhiei și a stării de afișare a obiectelor în Object Tree și dobândirea 

competențelor de creare a obiectelor compuse (Compound Resources) și a grupurilor logice de 

obiecte. 

Object Tree este vizualizatorul principal pentru examinarea structurii fizice a unui studiu, incluzând 

toate părțile și resursele. Este important să se înțeleagă semantica stărilor de afișare și modul de 

manipulare a ierarhiei prin crearea de obiecte compuse sau grupuri logice, care simplifică gestionarea 

obiectelor în spațiul 3D. 

Workflow: Navigarea de Bază și Controlul Afișării 

1. Controlul Stării de Afișare: 

o În vizualizatorul Object Tree, faceți clic succesiv pe pătratele de stare a afișării 

(Display Status Squares) de lângă fiecare nod (Ex: LandingGear_textured sau 

tire_frame). 

o Observație: 

▪ Un pătrat plin indică faptul că obiectul este complet afișat în Graphic Viewer 

(3D). 

▪ Un pătrat parțial umplut indică faptul că obiectul este doar parțial afișat (o parte 

din sub-componentele sale sunt ascunse). 

▪ Un pătrat gol indică faptul că obiectul este ascuns (Blanked) din Graphic 

Viewer. 

▪ Un X în pătrat indică faptul că obiectul nu are date 3D disponibile (geometrie). 
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2. Extinderea și Replicarea Ierarhiei: 

o Folosiți simbolurile + (pentru a extinde) sau - (pentru a ascunde) de lângă noduri 

pentru a naviga prin ierarhie. 

o Scurtătură: Folosiți tasta * (asterisc) de pe tastatura numerică (Number Pad) pentru 

a extinde toate nivelele arborelui, sau Click-dreapta → Expand All (Extindere 

Completă) pentru a vedea toate sub-componentele. 

 

Workflow: Crearea de Resurse Compuse (Compound Resources) 

1. Selectarea Părintelui: 

o În Object Tree, selectați un obiect existent în folderul Resources (ex: Line10 sau Unit 

10 Workcenter). 
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o Notă: Doar obiectele compuse (Compound Objects) pot servi ca părinți pentru a crea 

un nou obiect compus sub ele. 

2. Crearea Noului Obiect: 

o Alegeți Modeling → Create Part/Resource → Create Compound Resource din 

meniul principal. 

o Rezultat: Un nou obiect de tip CompoundResource1 (sau similar) este creat în 

folderul Resources, de obicei adăugat la baza listei. 

 

3. Redenumirea: 

o Selectați noul obiect CompoundResource1, apăsați tasta F2 sau faceți clic din nou pe 

numele său pentru a-l edita. 

o Redenumiți-l (Ex: My Compound Resource). 

4. Adăugarea de Sub-Componente: 

o Selectați resursele sau sub-componentele dorite (ex: desk_contents, Platform, toolcrib) 

din Object Tree. 

o Executați Drag-and-drop (trageți și plasați) aceste obiecte peste noul My Compound 

Resource. 

o Avertisment: Nu puteți adăuga simultan parts (piese) și resources (resurse) la același 

obiect compus. Un obiect compus de resursă poate conține doar resurse. 

o Notă: Această structură compusă va fi salvată înapoi în arborele de resurse original 

(și, implicit, va modifica structura bazei de date eMS) după ce se execută eMServer 

Selective Update. 
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Workflow: Crearea și Manipularea Grupurilor Logice (Groups) 

1. Deschiderea Logical Collections Tree: 

o Alegeți View → Viewers → Logical Collections Tree. 

2. Selectarea Grupului de Colecții: 

o În vizualizatorul Logical Collections Tree, selectați folderul Groups. 

3. Crearea Grupului: 

o Alegeți Tools → Group → Create Group din meniul principal. 

o În dialogul Create Group, introduceți un nume (Ex: My Group). 

o Lăsați Scope setat la Group Root și faceți clic pe OK. 

 

4. Popularea Grupului: 

o Din Graphic Viewer sau Object Tree, selectați obiectele dorite (Ex: Room 100 din 

Parts și Unit 10 Workcenter din Resources). 
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o Observație: Spre deosebire de obiectele compuse (Compound Objects), un Group 

poate conține orice combinație de parts, resources, compound parts sau compound 

resources (obiecte compuse de piese sau resurse). 

 

5. Manipularea Grupului: 

o Dacă selectați My Group în Logical Collections Tree și îl manipulați (rotație, 

translație) în Graphic Viewer, toate obiectele din grup se vor deplasa ca o singură 

unitate. 

o Vizualizarea Opțiunilor: Executați Click-dreapta pe My Group în Logical 

Collections Tree pentru a vedea opțiunile de manipulare specifice grupului (Ex: 

Create Group, Flatten Hierarchy, Replace Compounds with Groups, Export 

Groups to Excel). 

o Notă: Un grup este stocat doar în studiu și nu afectează structura originală a 

arborelui de resurse după o operațiune eMServer Selective Update. 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

76 

 

Înțelegerea modului de a citi stările de afișare și de a manipula ierarhia prin Compound Resources 

(pentru modificări structurale permanente) și Groups (pentru manipulare logică, temporară în cadrul 

studiului) este vitală. Grupurile permit analize rapide de fezabilitate (Ex: simulări de coliziune, 

afișare/ascundere rapidă) chiar înainte ca procesul detaliat să fie complet definit. 

 

2.1.5. Utilizarea Meniului Contextual (Click-dreapta Popup Menu) 

Obiectiv: Explorarea și aplicarea comenzilor rapide disponibile în meniurile contextuale (obținute 

prin Click-dreapta) din vizualizatoarele Object Tree și Graphic Viewer pentru manipularea rapidă 

a obiectelor și a vederii 3D. 

Meniul contextual din Process Simulate este dinamic și oferă funcții esențiale bazate pe obiectul 

selectat. Acesta permite controlul direct al culorii, stării de afișare și funcțiilor de manipulare a 

obiectelor. 

Workflow: Modificarea Proprietăților Obiectelor din Object Tree 

1. Schimbarea Culorii: 

o În vizualizatorul Object Tree, executați Click-dreapta pe obiectul dorit (Ex: Human 

(Jack)). 

o Din meniul contextual, navigați la opțiunea Modify Color (Modificare Culoare). 

o Selectați o culoare din paleta afișată (Ex: Albastru sau Rosu). 

 

o Faceți clic pe o zonă goală din Graphic Viewer pentru a deselecta obiectul și a vedea 

noua culoare aplicată. 
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o Anulare: Alegeți Edit → Undo (Anulare) din meniul principal pentru a reveni la 

culoarea inițială. 

 

2. Ascunderea Obiectului (Blanking): 

o Executați Click-dreapta pe același obiect (Ex: Human (Jack)). 

o Alegeți opțiunea Blank (Ascundere) sau folosiți scurtătura Alt+B. 
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o Rezultat: Obiectul dispare din Graphic Viewer, dar rămâne vizibil în Object Tree 

(starea de afișare devine pătrat gol). 

 

o Anulare: Alegeți Edit → Undo sau executați Click-dreapta pe obiect în Object Tree 

și alegeți Display (Alt+D). 

 

3. Afișarea Tuturor Obiectelor: 

o Executați Click-dreapta într-o zonă liberă a vizualizatorului Object Tree (nu pe un 

obiect anume). 

o Alegeți opțiunea Display All (Afișare Tot) pentru a face vizibile toate elementele 

(piese, resurse, etc.) care au geometrie 3D. 
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Meniul contextual este un instrument de productivitate esențial, permițând inginerului să efectueze 

rapid ajustări vizuale (culoare, stare de afișare) și să acceseze funcții de bază de editare, cum ar fi 

Undo, direct din arborescența de obiecte. 

 

2.2.CONFIGURAREA ȘI CONTROLUL VIZUALIZATORULUI GRAFIC 

 

Graphic Viewer este spațiul 3D în care se desfășoară simularea. Controlul eficient al perspectivei, al 

culorii de fundal și al modului de navigație (prin mouse sau dispozitive 3D) este fundamental pentru 

inspectarea detaliată a layout-ului și a traiectoriilor robotice. 

 

2.2.1. Controlul de Bază al Graphic Viewer 

Obiectiv: Setarea opțiunilor de afișare de bază, cum ar fi culoarea de fundal, și înțelegerea modurilor 

de navigație 3D. 

Workflow: Personalizarea Culorii de Fundal 

1. Accesarea Opțiunilor: 

o În Process Simulate, alegeți Tools → Options (Instrumente → Opțiuni). 

 

2. Navigare la Aspect: 

o În dialogul Options, faceți clic pe fila Appearance (Aspect). 
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o Navigați la secțiunea Graphic Viewer și selectați Background (Fundal). 

3. Configurarea Culorii: 

o Din lista derulantă, selectați Corners (Colțuri) în loc de Vertical. 

o Alegeți câte o culoare pentru fiecare colț. 

o Faceți clic pe Preview (Previzualizare) pentru a vizualiza schimbarea. 

o Faceți clic pe OK pentru a aplica și închide dialogul. 

o Notă: Selectarea Solid permite setarea unei singure culori uniforme pentru fundal. 

 

Workflow: Opțiuni de Mișcare cu Mouse-ul Standard 

1. Controlul Zoom-ului (Middle Mouse Button): 

o Apăsați și mențineți apăsat butonul din mijloc al mouse-ului (de obicei, rotița). 

o Mișcați mouse-ul spre dreapta pentru a face Zoom In (mărire) sau spre stânga pentru 

Zoom Out (micșorare). 
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2. Controlul Pan (Right Mouse Button - Opțional): 

o Apăsați și mențineți apăsat butonul din dreapta al mouse-ului. 

o Mișcați mouse-ul în orice direcție. Această acțiune controlează funcția Pan (deplasare 

laterală), în special atunci când este setată vizualizarea continuă (continuous 

viewing). 

3. Controlul Vizualizării (Middle + Right Mouse Button): 

o Apăsați și mențineți apăsate simultan butoanele din mijloc și din dreapta ale mouse-

ului. 

o Mișcarea mouse-ului va schimba punctul de vedere (unghiul camerei), permițând 

rotația scenei 3D. 

4. Zoom pe o Zonă Specifică (Area Zoom): 

o Țineți apăsată tasta [Alt] de pe tastatură. 

o Folosind butonul din stânga al mouse-ului, desenați un dreptunghi în jurul zonei de 

interes din Graphic Viewer. 

o Rezultat: Vederea va mări automat zona selectată (Zoom to Selection). 

Workflow: Opțiuni de Mișcare cu Space Mouse (Opțional) 

• Pan Dreapta/Stânga: Împingeți ușor manșonul lateral. 

• Pan Sus/Jos: Împingeți manșonul în jos sau trageți-l în sus. 

• Zoom: Împingeți manșonul înainte (spre ecran) sau trageți-l înapoi (spre utilizator). 

• Înclinare (Tilt): Rotiți manșonul înainte/înapoi. 

• Rotire (Spin): Rotiți manșonul în jurul axei sale verticale. 

• Rulare (Roll): Rotiți manșonul stânga/dreapta. 

Stăpânirea comenzilor Graphic Viewer permite explorarea rapidă și precisă a mediului de simulare 

3D. Prin personalizarea fundalului și utilizarea eficientă a mouse-ului standard (sau a unui dispozitiv 

3D opțional), utilizatorul poate inspecta cu ușurință detalii fine ale asamblărilor și traiectoriilor, 

îmbunătățind calitatea analizei. 

 

2.3.SELECȚIA ENTITĂȚILOR  

 

Selecția precisă a obiectelor în mediul 3D este esențială pentru orice operațiune de simulare, de la 

manipularea geometriei până la definirea traiectoriilor robotice. Process Simulate oferă diverse nivele 

de selecție (Pick Levels) și metode rapide (Mouse Wheel, PMI) pentru a izola și a lucra cu entități 

specifice. 
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2.3.1. Selecția Obiectelor în Graphic Viewer 

Obiectiv: Înțelegerea și utilizarea diferitelor nivele de selecție (Pick Levels), manipularea detaliată 

a entităților prin Load Entity Level și navigarea rapidă în ierarhie folosind rotița mouse-ului. 

Workflow: Nivelul de Selecție a Entităților (Pick Levels) 

1. Alegerea Nivelului de Selecție: 

o Alegeți un Entity Pick Level din bara de instrumente (cea mai probabilă setare inițială 

este Component). 

 

o Scurtătură: Tasta [F12] comută rapid între nivelurile de selecție. 

2. Selecția Obiectelor Kinematice vs. Non-Kinematice: 

o Obiect Non-Kinematic: Selectați un obiect staționar (Ex: o platformă). Observați că 

întregul obiect este evidențiat, indiferent de nivelul de selecție, deoarece nu are 

componente mobile distincte. 
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o Obiect Kinematic: Selectați o resursă cu mișcare (Ex: un robot sau un desk cu sub-

componente). Observați că doar o parte (o entitate) a obiectului este evidențiată, 

reflectând structura sa ierarhică de mișcare. 

 

Workflow: Accesarea Nivelului de Entitate 

1. Încărcarea Nivelului de Entitate: 

o Selectați un obiect non-kinematic (Ex: o platformă) în Graphic Viewer sau Object 

Tree. 

o Alegeți Modeling → Entity Level → Load Entity Level din meniul principal. 
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2. Examinarea Noii Ierarhii: 

o Observați în Object Tree că acum puteți extinde (expand) obiectul selectat pentru a 

vedea entitățile sale interne (Ex: fr1, fr2, etc., pentru platformă). 

o Selectați o entitate din această structură detaliată. 

3. Descărcarea Nivelului de Entitate: 

o Selectați din nou obiectul principal (platforma). 

o Alegeți Modeling → Entity Level → Unload Entity Level pentru a reveni la nivelul 

anterior de vizualizare (entitățile interne vor fi ascunse din ierarhie). 
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Workflow: Selecția și Manipularea Rapidă (Graphic Viewer) 

1. Modificarea Culorii Obiectului (Component Level): 

o Asigurați-vă că Pick Level este setat pe Component. 

 

o Executați Click-dreapta pe un obiect (Ex: operatorul uman) în Graphic Viewer și 

alegeți Modify Color. 
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o Selectați o culoare și faceți clic pe o zonă goală din Graphic Viewer pentru a vizualiza 

schimbarea culorii întregului obiect. 

 

o Anulare: Alegeți Edit → Undo. 
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2. Modificarea Culorii unei Părți (Entity Level): 

o Setați Pick Level la Entity. 

 

o Executați Click-dreapta pe o parte specifică a obiectului (Ex: trunchiul operatorului 

uman) și alegeți Modify Color. 

o Selectați o culoare. 

 

o Rezultat: Doar partea selectată își schimbă culoarea. 

o Anulare: Alegeți Edit → Undo. 
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3. Ascundere și Afișare: 

o Executați Click-dreapta pe un obiect și alegeți Blank (Alt+B) pentru a-l ascunde. 

 

o Executați Click-dreapta într-o zonă goală a Graphic Viewer și alegeți Display All 

pentru a readuce toate obiectele ascunse. 
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4. Navigarea Ierarhică (Mouse Wheel): 

o Selectați o entitate detaliată în Graphic Viewer (Ex: bottom_head_1 a operatorului 

uman). 

o Rulați rotița mouse-ului în sus un clic: Obiectul părinte direct al nodului selectat va 

fi evidențiat (urcare pe un nivel de ierarhie). 

o Continuați să rulați în sus pentru a ajunge la rădăcina arborelui. 

o Rulați rotița mouse-ului în jos un clic: Evidențierea revine la un nivel inferior 

(coborâre pe un nivel de ierarhie). 

o Continuați să rulați în jos până la nivelul inițial. 

 

Workflow: Vizualizarea și Selecția PMI (Product Manufacturing Information) 

1. Localizarea Datelor PMI: 

o În Object Tree, navigați la o componentă care include date PMI (Ex: toolcrib → 

pmi_notes_15). 

2. Zoom și Încărcare PMI: 

o Executați Click-dreapta pe obiectul PMI (pmi_notes_15) și alegeți Zoom to 

Selection (Alt+S). 
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o Alegeți Modeling → PMI → Load PMI din meniul principal. 

 

3. Examinarea PMI: 

o Rezultat: Detaliile PMI (note, dimensiuni, toleranțe geometrice) apar acum suprapuse 

peste modelul 3D al piesei în Graphic Viewer . 

o În Object Tree, extindeți pmi_notes_15 pentru a vedea detaliile structurale ale PMI 

(Ex: Note (24), Dimension (17), Feature Control Frame (12)). 
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4. Descărcarea PMI: 

o Selectați din nou pmi_notes_15 în Object Tree. 

o Alegeți Modeling → PMI → Unload PMI pentru a ascunde informațiile PMI din 

vederea 3D. 
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Selecția entităților reprezintă interacțiunea fundamentală dintre utilizator și model. Prin utilizarea 

inteligentă a nivelurilor de selecție, a comenzilor de navigare ierarhică cu mouse-ul și a funcțiilor de 

Load/Unload PMI, inginerul poate accesa și valida eficient atât structura logică, cât și detaliile de 

fabricație ale oricărei piese sau resurse din studiu. 

 

2.3.2. Metode Adiționale de Selecție Multiplă a Entităților 

Obiectiv: Însușirea tehnicilor eficiente de selecție simultană a mai multor entități (obiecte sau 

componente) în Object Tree și Graphic Viewer utilizând tastele de control. 

În proiectele complexe, selectarea rapidă a mai multor obiecte este vitală. Process Simulate oferă 

scurtături standard (Shift și Ctrl) și metode de selecție prin boxare (tragere cu mouse-ul) care 

optimizează fluxul de lucru. 

Workflow: Selecția Multiplă în Object Tree 

1. Selecția Discontinuă (Tasta [Ctrl]): 

o Selectați un prim nod în Object Tree. 

o Țineți apăsată tasta [Ctrl] și faceți clic pe nodurile suplimentare dorite, chiar dacă nu 

sunt consecutive. 

o Observație: Obiectele selectate sunt evidențiate în verde în Graphic Viewer. Această 

tastă funcționează atât în arbore, cât și în vizualizatorul grafic. 

2. Selecția pe Interval (Tasta [Shift]): 

o Selectați primul nod din intervalul dorit în Object Tree. 

o Țineți apăsată tasta [Shift] și faceți clic pe ultimul nod din acel interval. 

o Rezultat: Toate nodurile de la primul la ultimul nod selectat devin evidențiate. Această 

tastă funcționează doar în vizualizatorul Object Tree. 

 

Workflow: Selecția Multiplă în Graphic Viewer 

1. Selecția prin Boxare (Box Selection): 
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o Apăsați butonul stâng al mouse-ului și trageți o casetă (box) în jurul obiectelor dorite 

în Graphic Viewer. 

o Rezultat: Orice obiect a cărui geometrie este cel puțin parțial inclusă în casetă va fi 

selectat și evidențiat în verde. 

 

2. Deselecția: 

o Deselecția Totală: Faceți clic pe spațiul liber din jurul obiectelor din Graphic Viewer. 

o Deselecția Individuală: Țineți apăsată tasta [Ctrl] și faceți clic pe un obiect deja 

selectat (fie în Graphic Viewer, fie în Object Tree) pentru a-l deselecta individual. 

Workflow: Utilizarea Meniului View pentru Controlul Afișării 

1. Selectare Obiecte: Utilizați tasta [Ctrl] și mouse-ul pentru a selecta mai multe obiecte. 
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2. Ascunderea Obiectelor Selectate (Blank): 

o Alegeți View → Blank (Ascundere) sau folosiți scurtătura Alt+B. 

o Rezultat: Obiectele selectate dispar din Graphic Viewer. 

 

Cunoașterea acestor scurtături și metode de selecție eficientizează drastic timpul petrecut cu 

interacțiunea de bază cu modelul 3D, fiind esențială înainte de a trece la operațiuni complexe de 

modelare sau simulare. 

 

2.3.3. Utilizarea Toggle Display 

Obiectiv: Înțelegerea și utilizarea comenzii Toggle Display pentru a comuta rapid vizibilitatea între 

obiectele afișate și cele ascunse (blanked). 

Comanda Toggle Display este extrem de utilă pentru a izola rapid un set de obiecte de interes într-o 

scenă aglomerată. Prin activarea sa, toate obiectele vizibile devin invizibile și invers. 

Workflow: Comutarea Afișării (Toggle Display) 

1. Ascunderea Obiectelor de Interes: 

o Utilizați orice metodă de selecție (boxare, Ctrl+clic) pentru a selecta câteva obiecte. 

o Ascundeți-le utilizând View → Blank (Alt+B). 

o Rezultat: Acum, doar obiectele ascunse sunt invizibile. 

2. Comutarea Afișării: 

o Alegeți View → Toggle Display din meniul principal. 
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o Rezultat: Obiectele care erau anterior afișate devin ascunse, iar obiectele care erau 

ascunse (cele selectate de dumneavoastră la pasul 1) devin acum singurele obiecte 

vizibile în scenă. 

3. Repetarea Comutării: 

o Dacă ascundeți câteva dintre obiectele vizibile din nou, iar apoi aplicați Toggle 

Display din nou, stările de afișare vor fi inversate, readucând scena la starea inițială. 

 

Toggle Display este o funcție rapidă de izolare care permite utilizatorului să se concentreze exclusiv 

pe o sub-secțiune a mediului de lucru, facilitând inspecția detaliată, fără a fi nevoie de manipulări 

extinse ale ierarhiei. 

 

2.4. INTRODUCERE ÎN FILTRELE DE SELECȚIE 

 

Obiectiv: Utilizarea filtrelor de selecție pentru a selecta și a ascunde (blank) entități pe baza tipului 

lor specific (Ex: toate Frames). 

Filtrele de selecție (Selection Filters) sunt un instrument puternic care permite utilizatorului să ignore 

ierarhia și să selecteze global toate obiectele de un anumit tip, indiferent de locul unde se află în 

Object Tree. 

Workflow: Ascunderea Frame-urilor folosind Filtre 

1. Activarea Barei de Instrumente Selection (Dacă este Necesar): 

o Executați Click-dreapta pe orice bară de instrumente existentă și alegeți Selection 

pentru a o afișa. 
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2. Activarea Filtrului: 

o Din bara de instrumente Selection, faceți clic pe pictograma Select with Filter 

(Selectează cu Filtru). 

3. Alegerea Tipului de Entitate: 

o Din lista derulantă Selection Type, selectați tipul de entitate dorit (Ex: Frames). 



Bazele simulării robotice și analiza cinematică în Process Simulate 

97 

 

 

4. Selecția Globală: 

o Faceți clic pe pictograma Select All by Filter (Ctrl+A) din bara de instrumente. 

o Rezultat: Doar Frames-urile (cadrele de referință) din studiu sunt selectate. 

 

5. Ascunderea Cadrelor: 

o Alegeți View → Blank (Alt+B) din meniul principal. 

o Rezultat: Toate Frames-urile dispar din Graphic Viewer. 
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6. Dezactivarea Filtrului: 

o Faceți clic din nou pe pictograma Select with Filter sau pe pictograma Select de pe 

bara Viewing pentru a dezactiva modul de filtrare. 

Filtrele de selecție sunt indispensabile pentru sarcini de curățare a mediului 3D sau pentru operațiuni 

globale asupra unei categorii specifice de obiecte (Ex: afișarea/ascunderea tuturor punctelor, liniilor 

sau cadrelor), simplificând manipularea scenelor complexe. 

 

2.5.INTRODUCERE ÎN DISPLAY BY TYPE 

 

Comanda Display By Type oferă un mecanism centralizat de control al vizibilității în mediul 3D, 

permițând utilizatorului să ascundă sau să afișeze global toate entitățile de un anumit tip (Ex: toate 

Frames, Paths sau Dimensions). Aceasta este o alternativă la filtrele de selecție, dar cu o interfață 

grafică dedicată. 

 

2.5.1. Ascunderea tuturor Cadrelor (Frames) folosind Display By Type 

Obiectiv: Utilizarea dialogului Display By Type pentru a ascunde toate cadrele de referință (Frames) 

din studiul curent. 

Workflow: Ascunderea Cadrelor (Method 2) 

1. Afișare Completă: 

o Alegeți View → Display All din meniul principal pentru a vă asigura că toate obiectele 

sunt inițial vizibile. 



Bazele simulării robotice și analiza cinematică în Process Simulate 

99 

 

2. Deschiderea Dialogului: 

o Alegeți View → Display By Type (pictograma T). 

3. Selectarea Tipului de Entitate: 

o În dialogul Display By Type, navigați și selectați tipul de entitate dorit (Ex: Frames). 

 

4. Ascunderea Tipului Selectat: 

o Faceți clic pe pictograma Hide Selected Types (Ascunde Tipuri Selectate). 

5. Verificarea și Închiderea: 

o Rezultat: Toate Frames-urile din studiu dispar din Graphic Viewer. 

o Închideți dialogul Display By Type. 
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Display By Type este deosebit de util pentru curățarea rapidă a scenei 3D de elemente vizuale de 

fundal, cum ar fi Frames sau Notes, permițând concentrarea asupra geometriei și a mișcărilor 

robotice. 

 

2.6.MĂSURĂTORI ȘI UNITĂȚI DE MĂSURĂ 

 

Măsurarea distanțelor și a unghiurilor este o sarcină comună în simulare, esențială pentru validarea 

layout-ului și a traiectoriilor. Process Simulate permite utilizatorilor să efectueze măsurători precise 

și să ajusteze unitățile de măsură fundamentale utilizate în întregul mediu. 

 

2.6.1. Relația dintre Măsurători și Unități de Măsură 

Obiectiv: Măsurarea distanței dintre două obiecte, modificarea unităților liniare ale sistemului și 

observarea impactului asupra aceleiași măsurători. 

Workflow: Măsurarea Distanței Minime (Minimal Distance) 

1. Activarea Măsurătorii: 

o Faceți clic pe pictograma Minimal Distance (Distanță Minimă) de pe bara de 

instrumente Measurement (Măsurători). 

o Rezultat: Se deschide dialogul Minimal Distance. 

2. Selecția Obiectelor: 

o Faceți clic pe două obiecte distincte (Ex: două dulapuri de unelte sau o masă și o piesă) 

în Graphic Viewer pentru a le selecta ca First object și Second object. 

o Rezultat: Distanța minimă dintre cele două obiecte este afișată în câmpul Distance în 

unitățile curente (Ex: mm). 

3. Notarea Rezultatului: 

o Rețineți distanța afișată și închideți dialogul Minimal Distance. 
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Workflow: Schimbarea Unităților Sistemului 

1. Accesarea Opțiunilor: 

o Alegeți Tools → Options. 

2. Navigare la Unitatea: 

o În dialogul Options, faceți clic pe fila Units (Unități). 

3. Modificarea Unității Linii: 

o Schimbați tipul de unitate Linear (Liniară) din valoarea curentă (Ex: mm) la o altă 

unitate (Ex: inch). 

o Faceți clic pe OK pentru a aplica modificarea. 
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Workflow: Re-Măsurarea Distanței 

1. Re-activarea Măsurătorii: 

o Deschideți din nou dialogul Minimal Distance. 

 

2. Măsurarea cu Noile Unități: 

o Selectați aproximativ aceleași două obiecte de la pasul anterior. 

o Observație: Distanța afișată în câmpul Distance este aceeași, dar valoarea numerică 

este convertită automat pentru a reflecta noua unitate selectată (Ex: inch). 

3. Restabilirea Unității: 

o Închideți dialogul Minimal Distance. 
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o Alegeți Tools → Options, navigați la fila Units și schimbați unitatea Linear înapoi la 

mm (sau unitatea preferată). 

o Faceți clic pe OK. 

 

Workflow: Măsurarea Distanței Punct-la-Punct (Point to Point Distance) 

1. Activarea PTP Distance: 

o Faceți clic pe pictograma PTP Distance (Distanța Punct-la-Punct) de pe bara de 

instrumente Measurement. 

2. Configurarea Selecției: 

o Setați Pick Intent (Intenția de Selecție) la Snap (Agățare). 

o Setați Pick Level (Nivelul de Selecție) la Component. 
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3. Selecția Punctelor Specifice: 

o Pentru First Object, faceți clic pe baza (Ex: partea de jos) a primului obiect. 

o Pentru Second Object, faceți clic pe vârful (Ex: partea de sus) a celui de-al doilea 

obiect. 

4. Vizualizarea Coordonatelor: 

o Distanța totală și componentele sale pe axe (dX, dY, dZ) sunt afișate. 

o În dialogul Point To Point Distance, bifați Show dX, dY, dZ lines in the Graphic 

Viewer pentru a vizualiza vizual vectorii distanței pe cele trei axe. 

 

5. Închiderea: 

o Închideți dialogul Point To Point Distance. 

Ajustarea unităților în Process Simulate este o setare globală care afectează toate măsurătorile și 

coordonatele afișate. Funcțiile Minimal Distance și PTP Distance, combinate cu Pick Intent: Snap, 

oferă instrumentele necesare pentru validarea geometrică a oricărui layout. 
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2.7.VIZUALIZARE GRAFICĂ ȘI PERFORMANȚĂ 

 

Performanța vizualizării 3D este crucială în special în studiile complexe. Setările din fila 

Performance permit utilizatorului să echilibreze calitatea vizuală (Quality) cu viteza de randare 

(Speed), asigurând o experiență fluidă chiar și pe hardware limitat. 

 

2.7.1. Modificarea Performanței Vizualizării 

Obiectiv: Experimentarea cu setările Level of Details și Culling pentru a înțelege compromisul 

dintre calitatea grafică și viteza de randare. 

Workflow: Experimentarea Nivelului de Detalii (Level of Details) 

1. Centrarea Vederii: 

o Faceți clic pe pictograma Zoom To Fit (Alt+Z) pentru a centra obiectele în Graphic 

Viewer. 

2. Setarea pentru Viteză: 

o Alegeți Tools → Options și navigați la fila Performance (Performanță). 

o Mutați cursorul Level of Details (Nivel de Detaliu) complet spre Speed (Viteză). 

o Faceți clic pe OK. 
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3. Observarea Efectului: 

o Rezultat: Calitatea vizuală a obiectelor se reduce (geometria poate deveni 

simplificată) pentru a prioritiza viteza de interacțiune. 

o Faceți Zoom In și Zoom Out folosind mouse-ul și observați fluiditatea. 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

107 

 

4. Setarea pentru Calitate/Performanță Optimă: 

o Redeschideți Options → Performance. 

o Mutați cursorul Level of Details foarte aproape de Quality (Calitate) (o setare optimă 

este adesea la două clicuri de Quality). 

o Setări OpenGL: Alegeți nivelul de accelerare OpenGL adecvat hardware-ului (Ex: 

V1.1 (Highest supported) sau V1.5 (Vertex buffer objects)). 

o Faceți clic pe OK și observați diferența de detalii. 

 

Workflow: Experimentarea Culling-ului 

1. Activarea Culling: 

o Redeschideți Options → Performance. 

o Bifați Cull parts with less than: (Omite piese mai mici de:). 

o Introduceți o valoare mare (Ex: 0.05 %) în câmpul procentual. 

o Faceți clic pe OK. 
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2. Observarea Efectului: 

o Rezultat: Obiectele mici din scenă (sub pragul de 0.05%) sunt ascunse automat pentru 

a reduce încărcarea grafică. 

o Atenție: Această opțiune nu trebuie utilizată atunci când obiectele mici (Ex: puncte de 

sudură - welds, sau cadre de poziționare - PLPs) sunt critice pentru vizualizare. 

 

3. Restabilirea Setării Tipice: 

o Redeschideți Options → Performance. 
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o Debifați Cull parts with less than: (sau setați o valoare foarte mică, Ex: 0.015 %) 

pentru a restaura afișarea tuturor obiectelor. 

o Faceți clic pe OK. 

 

 

Gestionarea setărilor de performanță este un aspect cheie al lucrului cu simulări mari. Prin ajustarea 

Level of Details și a Culling-ului, utilizatorul poate menține un mediu de lucru rapid, fără a sacrifica 

calitatea necesară pentru validarea finală a proceselor. 
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2.7.2. Modificarea Vizualizării Grafice  

Obiectiv: Modificarea modului de randare 3D (Shaded, Wireframe, Transparent) și utilizarea 

Dynamic Clipping pentru a inspecta geometria internă a obiectelor. 

Vizualizarea grafică nu se referă doar la estetică, ci este un instrument analitic. Comutarea între 

diferite moduri de randare și utilizarea funcției de clipping permite inginerilor să analizeze detalii 

geometrice, traiectorii și asamblări în profunzime. 

Workflow: Modurile de Randare (Shaded, Wireframe, Feature Lines) 

1. Izolarea Obiectului (Display Only): 

o În Object Tree, navigați la o componentă (Ex: desk_contents). 

 

o Executați Click-dreapta și alegeți Display Only (Afișare Doar). Toate celelalte 

obiecte din studiu sunt ascunse. 

 

2. Configurarea Opțiunilor de Vizualizare: 

o Alegeți Tools → Options și navigați la fila Graphic Viewer. 

o Bifați Show Silhouette in Wireframe Mode (Afișează Silueta în Modul Wireframe). 

o Faceți clic pe OK. 
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3. Activarea Modului Feature Lines: 

o Alegeți View → Feature Lines (Linii Caracteristice). 

o Rezultat: Obiectele sunt afișate folosind doar liniile caracteristice, oferind o 

perspectivă clară a geometriei. 

 

4. Activarea Modului Wireframe: 

o Alegeți View → Wireframe Mode (Modul Cadru de Sârmă). 

o Rezultat: Obiectele sunt randate doar ca o rețea de linii, permițând vizualizarea 

obiectelor interne (datorită opțiunii Show Silhouette setate anterior). 
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5. Activarea Modului Shaded (Umbre): 

o Alegeți View → Shaded Mode (Modul Umbrit). 

o Rezultat: Revenirea la randarea solidă, cu umbre, pentru o vizualizare realistă. 

 

6. Activarea Feature Lines Over Solid: 

o Alegeți View → Feature Lines Over Solid (Linii Caracteristice Peste Solid). 
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o Rezultat: Randarea solidă (Shaded) este menținută, dar liniile caracteristice sunt 

suprapuse, îmbunătățind claritatea marginilor. 

 

7. Comutare Rapidă a Modurilor: 

o Apăsați tasta [F10] succesiv de mai multe ori. Această scurtătură comută rapid între 

modurile de randare. 

o Reveniți la Shaded Mode. 

Workflow: Modificarea Vizualizării unui Singur Obiect (Transparent) 

1. Setarea Transparenței: 

o Selectați un obiect (Ex: operatorul uman). 

o Alegeți View → Object Viewing → Transparent (Transparent). 
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2. Observarea Efectului: 

o Deselectați obiectul. 

o Rotiți vederea în Graphic Viewer (Mouse Middle + Right Click). 

o Rezultat: Puteți vedea acum prin obiectul transparent, fiind util pentru selectarea sau 

vizualizarea componentelor interne ale unui ansamblu complicat. 

3. Revenirea la Shaded: 

o Selectați obiectul transparent. 

o Alegeți View → Object Viewing → Shaded (Umbre). 

o Deselectați obiectul. 
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Workflow: Utilizarea Dynamic Clipping (Secționare Dinamică) 

1. Centrarea Punctului de Interes: 

o Selectați un punct sau un obiect de interes în Graphic Viewer. 

o Alegeți View → Graphic Viewer → View Center (Alt+C) pentru a seta acel punct 

în centrul ecranului. 

 

2. Activarea Modului Clipping: 

o Alegeți View → Dynamic Clipping (Secționare Dinamică) pentru a intra în modul de 

clipping. 

3. Configurarea Planului de Secționare: 
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o Alegeți View → Dynamic Clipping Plane Settings (Setări Plan de Secționare 

Dinamică). 

o În dialogul deschis, glisați cursorul Clipping Plane (Plan de Secționare) puțin distanță 

de Camera (Cameră). 

4. Vizualizarea Secționării: 

o Utilizați mouse-ul pentru a roti sau mări vederea (Zoom In). 

o Rezultat: Geometria care blochează vederea către centrul stabilit este tăiată 

(secționată dinamic), permițând o vizualizare mai bună a zonei de interes interne. 

 

5. Ieșirea din Clipping: 

o Închideți dialogul Dynamic Clipping Plane Settings. 

o Alegeți View → Dynamic Clipping pentru a ieși din modul de secționare. 

Funcțiile de vizualizare avansată din Process Simulate, cum ar fi Transparent și Dynamic Clipping, 

extind capacitățile de analiză dincolo de simpla randare solidă. Acestea le permit inginerilor să 

exploreze structurile interne, să depaneze problemele de asamblare și să verifice detaliile fără a 

modifica permanent geometria modelului. 
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2.8.ADĂUGAREA UNUI FUNDAL GRAFIC AVANSAT 

 

Pentru a crea simulări cât mai realiste, Process Simulate oferă suport pentru mapări de texturi (texture 

maps) și integrarea de date din scanări 3D (norii de puncte - Point Clouds). Aceste funcții sunt 

esențiale pentru studiile de validare în contextul fizic real al fabricii. 

 

2.8.1. Utilizarea Mapărilor de Texturi 

Obiectiv: Vizualizarea și inserarea componentelor cu texturi mapate pentru a îmbunătăți realismul 

mediului 3D. 

Texture map este o imagine digitală aplicată geometriei 3D a unui obiect pentru a-i conferi un aspect 

realist (ex: suprafață metalică, sticlă, zidărie). 

Workflow: Vizualizarea Componentelor cu Texturi 

1. Localizarea Obiectului Texturat: 

o În Object Tree, navigați la folderul Parts și localizați un obiect texturat (Ex: 

LandingGear_textured). 

2. Zoom la Selecție: 

o Executați Click-dreapta pe obiectul LandingGear_textured și alegeți Zoom to 

Selection (Alt+S). 

 

3. Inspectarea Texturii: 

o Folosiți funcțiile de navigare 3D (Pan, Zoom, Rotate) în Graphic Viewer. 

o Observație: Observați cum obiectul pare lucios și metalic, datorită mapării texturii 

aplicate pe suprafața sa. 
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Workflow: Inserarea și Poziționarea Componentelor Texturate 

1. Inserarea Componentelor: 

o Alegeți Modeling → Insert Component din meniul principal. 

o În dialogul Insert Component, navigați la directorul de biblioteci (Ex: 

\sysroot\Libraries\RESOURCES2\FACILITIES). 

o Selectați fișierele de geometrie care conțin texturi (Ex: floor.cojt și wall_l.cojt). 

o Faceți clic pe Open (Deschide). 

 

2. Poziționarea Pereților: 

o Selectați componentele nou inserate (Ex: peretele texturat, wall_l.cojt). 

 

o Alegeți Tools → Placement → Placement Manipulator (Instrumente → Amplasare 

→ Manipulator de Amplasare). 
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o În dialogul Placement Manipulator, aplicați o rotație de 90 de grade în jurul axei X 

(Clic pe Rx, introduceți 90, apoi [Enter]) pentru a pune peretele vertical. 

3. Translația Pereților: 

o Cu peretele selectat, utilizați Placement Manipulator din nou. 

o Introduceți o valoare mare de translație pe axa Y (Ex: 4300) și apăsați [Enter] pentru 

a muta peretele în poziția dorită. 

 

o Faceți clic pe Close. 

Utilizarea componentelor cu texturi mapate, cum ar fi podelele și pereții de fabrică, este o metodă 

eficientă de a oferi context vizual studiului. Acestea nu doar îmbunătățesc aspectul, ci ajută la 

imersiunea în mediul de producție real. 

 

2.8.2. Utilizarea Norilor de Puncte 

Obiectiv: Configurarea directorului rădăcină pentru norii de puncte și inserarea unui nor de puncte 

într-un studiu Process Simulate. 

Norii de puncte sunt seturi masive de date 3D obținute din scanarea laser a unei facilități reale. Ei 

servesc ca o reprezentare precisă, dar statică, a mediului fizic al fabricii. Integrarea lor permite 

plasarea cu precizie a echipamentelor noi în contextul existent. 

Workflow: Setarea Directorului Rădăcină (Point Cloud Root) 

1. Accesarea Opțiunilor: 

o Alegeți Tools → Options. 

2. Configurarea Point Cloud: 
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o În dialogul Options, navigați la fila General și faceți clic pe butonul Point Cloud. 

3. Setarea Rădăcinii: 

o În dialogul Point Cloud Options, faceți clic pe Browse (Răsfoire) de lângă câmpul 

Point Cloud Root. 

o Navigați și selectați folderul care conține fișierele norilor de puncte (Ex: 

\sysroot\Sample point cloud folder). 

o Faceți clic pe OK pentru a închide ambele dialoguri. 

 

Workflow: Inserarea unui Nor de Puncte 

1. Activarea Inserției: 

o Alegeți Tools → Point Cloud → Insert Point Cloud din meniul principal. 

2. Configurarea Norului: 

o În dialogul Insert Point Cloud, introduceți un nume (Ex: MotorFactory) în câmpul 

Name. 

o Pentru Point Cloud file, faceți clic pe Browse, navigați la directorul setat anterior și 

selectați fișierul norului de puncte dorit (Ex: MyFactory.pod). 

3. Inserațea: 

o Faceți clic pe Insert (Inserează). 
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4. Vizualizarea: 

o Rezultat: Datele norului de puncte sunt afișate în Graphic Viewer și apar ca un nou 

nod în Object Tree. 

o Utilizați funcțiile de rotire, pan și zoom pentru a explora mediul scanat. 

Prin integrarea norilor de puncte, Process Simulate oferă un nivel de precizie contextuală de neegalat. 

Această reprezentare a mediului existent (as-is) este crucială pentru efectuarea analizelor de 

interferență și pentru planificarea amplasării echipamentelor noi (roboți, unelte) în spațiile industriale 

existente. 
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3. COMENZILE DE AMPLASARE  

 

 

Amplasarea precisă a obiectelor în spațiul 3D al simulării este un pas critic. Acest capitol detaliază 

instrumentele Process Simulate care permit utilizatorului să mute, să rotească și să alinieze 

componentele (piese, resurse, unelte) rapid și exact, inclusiv funcții de mișcare interactivă și definirea 

de sisteme de coordonate locale (Frames). 

 

3.1. INTRODUCERE ÎN FAST PLACEMENT ȘI RESTORE DESIGN RELATIVE 

LOCATION 

 

Fast Placement (Amplasare Rapidă) este un instrument interactiv, bazat pe mouse, care permite 

deplasarea rapidă a obiectelor pe planul XY. Comanda Restore Position (Restabilire Poziție) este 

complementară, oferind o metodă rapidă de a anula modificările de poziție. 

 

3.1.1. Utilizarea Fast Placement 

Obiectiv: Folosirea funcției Fast Placement pentru a deplasa interactiv obiectele pe ecran. 

Workflow: Utilizarea Fast Placement 

1. Setarea Vederii: 

o Alegeți View → Graphic Viewer → View Point → Top View Point (Punct de Vedere 

de Sus). 

2. Configurarea Selecției: 

o Din bara de instrumente Selection, setați Pick Level (Nivel de Selecție) la 

Component. 

3. Activarea Fast Placement: 

o Faceți clic pe pictograma Fast Placement din bara de instrumente. 

o Selectați un obiect în Graphic Viewer și începeți să îl trageți (drag) cu mouse-ul. 

o Observație: Deplasarea funcționează eficient doar pe planul XY. Nu funcționează pe 

direcția Z. 

4. Revenirea la Modul Normal: 

o Când ați terminat, faceți clic pe Select din bara de instrumente. 
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o Alegeți Zoom to Fit pentru a recentra vederea. 

 

Workflow: Anularea Schimbărilor de Poziție 

1. Metoda 1: Edit → Undo: 

o Utilizați Edit → Undo (Anulare) din meniul principal pentru a anula ultima 

amplasare. 

o Repetați de câte ori este necesar pentru a anula toate mișcările. 

2. Metoda 2: Restore Position: 

o Mutați din nou un obiect folosind Fast Placement în mai multe locații. 

o Selectați obiectul mutat în Graphic Viewer (sau selectați mai multe obiecte, ținând 

tasta [Ctrl] apăsată). 

o Alegeți Tools → Placement → Restore Position (Restabilire Poziție). 

o Rezultat: Obiectul revine la poziția sa inițială dintr-un singur clic. 

o Avertisment (istoric): Deși documentată, verificați funcționalitatea Restore Position 

în versiunea dumneavoastră de software. 

Fast Placement este un utilitar rapid pentru ajustările grosiere ale layout-ului. Pentru a gestiona 

mișcările precise, se recomandă utilizarea Placement Manipulator (capitolele următoare), iar 

Restore Position asigură revenirea la starea inițială de proiectare. 

 

3.2. COMANDA PLACEMENT: SCHIMBAREA COMPORTAMENTULUI DE SELECȚIE 

ȘI CREAREA DE CADRE 

 

Cadrele de referință (Frames) sunt sisteme de coordonate locale care definesc poziția și orientarea 

(X, Y, Z, Rx, Ry, Rz) în spațiul 3D. Crearea de cadre este fundamentală pentru definirea traiectoriilor 
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robotice, a locațiilor de prindere (gripping points) și a poziționării precise a pieselor în raport cu un 

anumit punct. 

 

3.2.1. Crearea unui Cadru 

Obiectiv: Însușirea diferitelor metode de definire a unui cadru de referință. 

Workflow: Crearea unui Cadru prin 6 Valori (Create Frame by 6 Values) 

1. Activarea Comenzii: 

o Alegeți Modeling → Create Frame → Create Frame by 6 Values (Modelare → 

Creare Cadru → Creare Cadru prin 6 Valori). 

2. Amplasarea Interactivă: 

o Faceți clic pe un punct în Graphic Viewer pentru a stabili originea cadrului. 

o Observație: Puteți continua să faceți clic pe poziții noi în Graphic Viewer pentru a 

schimba interactiv amplasarea cadrului. Coordonatele (Relative Position) sunt 

actualizate în dialog. 

3. Finalizarea: 

o Când poziția este corectă, faceți clic pe OK în dialogul Create Frame By 6 Values. 

o Rezultat: Cadrul este afișat ca un sistem de axe (X, Y, Z) în Graphic Viewer și este 

listat în folderul Frames din Object Tree. 
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Workflow: Crearea unui Cadru prin 3 Puncte (Create Frame By 3 Points) 

1. Activarea Comenzii: 

o Alegeți Modeling → Create Frame → Create Frame By 3 Points. 

2. Definirea Originii: 

o Selectați un punct în Graphic Viewer pentru a stabili originea cadrului (punctul 1). 

3. Definirea Axelor X și XY: 

o Selectați un al doilea punct pentru a defini direcția axei X a cadrului (punctul 2). 

o Selectați un al treilea punct pentru a defini planul XY al cadrului (punctul 3). 

4. Regula Mâinii Drepte: 

o Observație: Axa Z este determinată automat prin regula mâinii drepte pe baza 

planului XY. Dacă axa Z indică în direcția greșită, faceți clic pe butonul Flip Frame 

(Întoarce Cadru) din dialog. 

5. Finalizarea: 

o Faceți clic pe OK. 
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Workflow: Crearea unui Cadru Între 2 Puncte (Create Frame Between 2 Points) 

1. Activarea Comenzii: 

o Alegeți Modeling → Create Frame → Create Frame Between 2 Points. 

2. Selecția Punctelor: 

o Selectați un punct în Graphic Viewer pentru a defini primul punct. 

o Selectați un al doilea punct pentru a defini al doilea punct. 

3. Poziționarea: 

o Cadrul este creat implicit la 50% din distanța dintre cele două puncte. Folosiți slider-

ul din dialog pentru a ajusta poziția cadrului de-a lungul liniei dintre cele două puncte, 

dacă este necesar. 

4. Finalizarea: 

o Faceți clic pe OK. 

Workflow: Crearea unui Cadru după Centrul Cercului (Create Frame by Circle Center) 

1. Activarea Comenzii: 

o Alegeți Modeling → Create Frame → Create Frame By Circle Center. 
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2. Selecția celor 3 Puncte: 

o Selectați trei puncte succesive în Graphic Viewer care definesc un cerc. 

o Observație: Cadrul este creat la centrul cercului format de cele trei puncte. Primul 

punct determină de obicei direcția axei X. 

o Sfat: Această metodă este utilă pentru cercurile sau cilindrii geometrici imperfecți. 

3. Finalizarea: 

o Faceți clic pe OK. 
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Cadrele de referință sunt coloana vertebrală a poziționării precise în Process Simulate. Prin crearea 

cadrelor, utilizatorul stabilește sisteme de coordonate clare pentru toți ceilalți parametri de amplasare, 

de la locațiile de sudură la pozițiile de pick-and-place. 

 

3.3. INTRODUCERE ÎN PLACEMENT MANIPULATOR 

 

Placement Manipulator (Manipulatorul de Amplasare) este cel mai important instrument pentru 

mișcarea și orientarea precisă a instanțelor de obiecte (resurse, piese) în mediul 3D. Acesta combină 

interacțiunea grafică (tragere de axe) cu controlul numeric (introducerea de valori). 

 

3.3.1. Deplasarea și Rotirea Instanțelor pe Ecran 

Obiectiv: Utilizarea dialogului și a mânerelor din Placement Manipulator pentru a deplasa și a roti 

obiecte, și înțelegerea conceptului de Frame of Reference (Cadru de Referință). 

Workflow: Deschiderea și Utilizarea Manipulatorului 

1. Configurarea Selecției: 

o Asigurați-vă că Pick Level este setat la Component. 

2. Selectarea Obiectului: 

o Selectați un obiect în Graphic Viewer (Ex: LandingGear_textured). 

3. Activarea Manipulatorului: 

o Alegeți Tools → Placement → Placement Manipulator (Alt+P). 
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o Rezultat: Apare dialogul Placement Manipulator și un cadru mare cu arce 

(Manipulator Frame) se afișează la centrul obiectului selectat. 

 

4. Deplasarea Interactivă (Translate): 

o În Graphic Viewer, selectați și trageți axa roșie X a Manipulator Frame-ului. 

o Observație: Coordonatele relative (distanța parcursă de la momentul selecției) sunt 

afișate în caseta Translate a dialogului. 

o Trageți axa verde Y pentru a deplasa pe acea direcție. 

o Trageți pătratul alb (între X și Y) pentru a deplasa pe planul XY. 

5. Rotirea Interactivă (Rotate): 

o Trageți arcul verde al Manipulator Frame-ului pentru a roti obiectul în jurul axei Y. 

6. Controlul Prin Valori: 

o În dialogul Placement Manipulator, utilizați butoanele săgeți (sau introduceți direct 

valori) în câmpurile Translate (X, Y, Z) sau Rotate (Rx, Ry, Rz) pentru a deplasa 

obiectul cu pasul definit (Step Size). 

Workflow: Schimbarea Cadrului de Referință 

1. Cadru de Referință Implicit: 

o Observați în dialogul Placement Manipulator că Frame of Reference (Cadru de 

Referință) este setat implicit la Geometric center (Centrul Geometric). 

2. Schimbarea la Working Frame: 

o Schimbați Frame of Reference în Working Frame (Cadru de Lucru, care este setat 

la File → Project Management). 



Bazele simulării robotice și analiza cinematică în Process Simulate 

130 

 

3. Observarea Schimbării: 

o Rotiți din nou obiectul în Graphic Viewer (Ex: în jurul axei Y). 

o Observație: Mișcarea se realizează acum în raport cu orientarea Working Frame, 

care este diferită de centrul geometric al obiectului. 

 

Workflow: Vizualizarea Coordonatelor Absolute și Reset 

1. Vizualizarea Coordonatelor Absolute: 

o Faceți clic pe Expand Dialog (Extinde Dialog) în Placement Manipulator (de obicei, 

o săgeată în jos). 

o Asigurați-vă că același cadru (Ex: Working frame) apare atât în Frame of Reference 

cât și în Location relative to. 

o Observație: În tabelul din partea de jos a dialogului, sunt afișate coordonatele absolute 

curente ale obiectului în raport cu cadrul de referință selectat. Nu este recomandată 

introducerea directă de valori în acest tabel; el servește ca afișaj al poziției. 

2. Resetare: 

o Faceți clic pe Reset în dialogul Placement Manipulator. Obiectul revine la poziția 

pe care o avea la momentul deschiderii dialogului. 

3. Închiderea: 

o Faceți clic pe Close (Închide). 
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Placement Manipulator este instrumentul de bază pentru inginerul de simulare, oferind controlul 

necesar pentru a poziționa resursele cu precizie. Înțelegerea conceptului de Frame of Reference este 
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vitală, deoarece asigură că mișcările (translații și rotații) sunt aplicate corect, în raport cu sistemul de 

coordonate dorit. 

 

3.3.2. Relația dintre Placement Manipulator, Măsurători și Unități  

Obiectiv: Explorarea modului în care Placement Manipulator interacționează cu unitățile de măsură 

ale sistemului și utilizarea instrumentelor de măsură pentru a valida poziționarea. 

Setările de unități din Process Simulate influențează direct afișarea coordonatelor și valoarea Step 

Size în Placement Manipulator. Această activitate demonstrează consistența dintre sistemul de 

măsură și instrumentele de manipulare. 

Workflow: Măsurarea și Manipularea 

1. Accesarea Manipulatorului: 

o Selectați un obiect în Graphic Viewer (Ex: Black_Tire2). 

o Alegeți Tools → Placement → Placement Manipulator (Alt+P). 

o În dialog, setați Working frame ca Frame of Reference. Nu închideți dialogul. 

 

2. Măsurarea Distanței PTP (Point to Point): 

o Faceți clic pe pictograma PTP Distance (Distanță Punct-la-Punct) de pe bara de 

instrumente Measurement. 

o Setați Pick Intent la Snap și Pick Level la Component. 
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o Măsurați distanța dintre un punct pe primul obiect (Ex: baza Black_Tire2) și un punct 

pe al doilea obiect (Ex: vârful pallet1). 

o Observație: Distanța (Ex: 5116.27 mm) și componentele sale (dX, dY, dZ) sunt afișate 

în unitățile curente (mm). 

o Închideți dialogul Point to Point Distance. 

 

 

3. Măsurarea Distanței Minime (Minimal Distance): 

o Faceți clic pe pictograma Minimal Distance (Distanță Minimă). 

o Măsurați distanța minimă dintre cele două obiecte (Ex: Black_Tire2 și pallet1). 

o Lăsați dialogul Minimal Distance deschis. 
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4. Deplasarea Incrementală (Translate): 

o În dialogul Placement Manipulator, observați unitățile Step Size (Ex: 100.00 mm). 

o Faceți clic pe link-ul Step Size din secțiunea Translate, introduceți o valoare (Ex: 

100), apoi OK. 

o Faceți clic pe axa Z și apoi pe săgeata de deplasare (Ex: de două ori) pentru a ridica 

obiectul. 

5. Anularea Poziționării: 

o Faceți clic pe Reset în dialogul Placement Manipulator pentru a anula toate mișcările 

făcute de la deschiderea acestuia. 

o Închideți dialogul Placement Manipulator și Minimal Distance. 

 

6. Schimbarea Unităților și Re-examinarea: 
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o Alegeți Tools → Options → Units. 

o Schimbați unitatea Linear la inch (țol) și creșteți Decimal places (Zecimale) la 3. 

o Redeschideți Placement Manipulator și Minimal Distance pentru aceleași obiecte. 

o Observație: Valorile Translate și Minimal Distance sunt acum afișate în inch, 

demonstrând că schimbarea unității este aplicată la nivel de sesiune. 

 

 

 

3.3.3. Deplasarea Incrementală a Obiectelor de la un Cadru de Referință 

Obiectiv: Utilizarea mărimilor de pas (Step Size) liniare și de rotație pentru a deplasa obiecte 

incremental, în raport cu un cadru de referință selectat. 

Workflow: Rotirea Incrementală 

1. Accesarea Manipulatorului: 

o Selectați un obiect. 

o Alegeți Tools → Placement → Placement Manipulator (Alt+P). 
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2. Setarea Pasului de Rotație: 

o Faceți clic pe link-ul Step Size din secțiunea Rotate. 

o În dialogul Step Size care apare, introduceți o valoare pentru Rotation step (deg) (Ex: 

45). 

o Faceți clic pe OK. 

 

 

3. Rotirea Incrementală: 

o Faceți clic pe axa de rotație dorită (Ex: Rx - Rotație în jurul axei X). 

o Folosiți săgețile Move Negative și Move Positive pentru a roti obiectul în pași de 45 

de grade. 
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o Avertisment: Evitați să folosiți săgețile Move Negative To Collision și Move 

Positive To Collision, deoarece rotația continuă până la detectarea unei coliziuni, ceea 

ce nu este relevant pentru această demonstrație. 

4. Schimbarea Cadrului de Referință: 

o În dialogul Placement Manipulator, schimbați Frame of Reference la Working 

frame. 

o Rotiți din nou obiectul incremental. 

o Observație: Obiectul se rotește acum în jurul axei X a cadrului de lucru, nu în jurul 

centrului său geometric. 

5. Finalizarea: 

o Faceți clic pe Reset pentru a anula modificările. 

o Faceți clic pe Close. 

 

Deplasarea incrementală cu Placement Manipulator oferă un control fin asupra mișcării, esențial 

pentru alinierea precisă a componentelor. Posibilitatea de a schimba dinamic Step Size și Frame of 

Reference face din acest instrument o componentă flexibilă pentru orice sarcină de amplasare. 

 

3.4. INTRODUCERE ÎN RELOCATE 

 

Comanda Relocate (Repoziționează) este utilizată pentru a muta o instanță de obiect dintr-un cadru 

de referință sursă (From frame) într-un cadru de referință destinație (To frame). Aceasta este o 
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metodă geometrică avansată de amplasare, asigurând că un obiect își menține poziția relativă, dar se 

repoziționează pe baza diferenței dintre două sisteme de coordonate. 

 

3.4.1. Relocarea unui Obiect față de Două Cadre Noi 

Obiectiv: Utilizarea comenzii Relocate pentru a muta un obiect folosind două puncte definite 

interactiv în Graphic Viewer ca referințe de cadre. 

Workflow: Relocare prin Puncte Definite Interactiv 

1. Pregătirea: 

o Setați Pick Intent la Snap și Pick Level la Component. 

o Selectați obiectul de mutat (Ex: o platformă). 

 

2. Activarea Comenzii: 

o Alegeți Tools → Placement → Relocate (Alt+R). 

o Rezultat: Dialogul Relocate se deschide, iar obiectul selectat este afișat în lista 

Objects. 

3. Definirea Cadrului Sursă (From frame): 

o Faceți clic în caseta From frame (Cadru Sursă). 

o Faceți clic pe o locație (sau un colț al unui obiect) în Graphic Viewer. Această locație 

devine From frame. 

4. Definirea Cadrului Destinație (To frame): 

o Faceți clic în caseta To frame (Cadru Destinație). 

o Faceți clic pe o altă locație în Graphic Viewer. Această locație devine To frame. 
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5. Aplicarea Relocării: 

o Faceți clic pe Apply (Aplică). 

o Rezultat: Obiectul este mutat pe distanța și în direcția definite de vectorul dintre From 

frame și To frame. 
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6. Finalizarea: 

o Nu închideți dialogul Relocate. 

 

3.4.2. Relocarea unui Obiect față de Două Cadre Existente 

Obiectiv: Utilizarea comenzii Relocate pentru a muta un obiect între două cadre de referință deja 

existente. 

Cadrele existente pot fi: originea proprie a obiectului (Self Origin), World Frame, cadre definite 

anterior (Frames) sau colțurile (originele) altor entități. 

Workflow: Relocare prin Cadre Existente (Ex: Colțuri de Obiect) 

1. Selectarea Colțului Sursă (From frame): 

o În dialogul Relocate deschis, faceți clic în caseta From frame. 

o Faceți clic pe un colț specific (punct de referință) al unui obiect (Ex: colțul superior al 

floor_a). 

2. Selectarea Colțului Destinație (To frame): 

o Faceți clic în caseta To frame. 

o Faceți clic pe colțul corespunzător al obiectului destinație (Ex: colțul superior al 

Platform). 
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3. Setarea Orientării: 

o Bifați caseta Maintain orientation (Menține Orientarea). 

4. Aplicarea Relocării: 

o Faceți clic pe Apply. 

o Rezultat: Obiectul este deplasat pe distanța definită de vectorul From Frame la To 

Frame, în timp ce orientarea sa originală este menținută. 

 

Comanda Relocate este de neprețuit pentru alinierea precisă a componentelor sau pentru mutarea 

unui întreg ansamblu într-o nouă locație a layout-ului. Folosirea opțiunii Maintain orientation 

asigură că, deși poziția este ajustată, orientarea unghiulară rămâne neschimbată, ceea ce este esențial 

pentru menținerea validității traiectoriilor și a cinematicii.   
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4. INTRODUCERE ÎN CINEMATICĂ 

 

 

Cinematica este studiul mișcării fără a lua în considerare forțele care o provoacă. În Process Simulate, 

cinematica este vitală pentru definirea comportamentului roboților și al dispozitivelor precum ușile, 

cleștii sau conveioarele. Acest capitol introduce instrumentele de bază pentru a manipula articulațiile 

(Joints) și a salva pozițiile specifice (Poses) ale acestor dispozitive. 

 

4.1. FUNDAMENTELE CINEMATICII 

4.1.1. Acționarea manuală a articulațiilor unui obiect simplu 

Obiectiv: Încărcarea studiului de demonstrație Door Kinematics și manipularea interactivă a 

articulațiilor sale (Jogging) pentru a înțelege mișcarea cinematică. 

Workflow: Încărcarea Studiului de Demonstrație 

1. Închiderea Proiectului Curent: 

• Alegeți File → Close Project. 

• Confirmați închiderea cu Yes, dar selectați No la solicitarea de actualizare a 

eMServer. 

2. Deschiderea Proiectului de Cinematică: 

• Alegeți File → Open Project. 

• Selectați proiectul Project_209S și faceți clic pe OK. 

3. Setarea Working Folder: 

• În Navigation Tree, navigați la colecția Working Folders. 

• Executați Click-dreapta pe folderul alocat utilizatorului (Ex: User1 folder) și alegeți 

Check Out, apoi OK. 
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• Alegeți File → Project Management → Set Working Folder. 

4. Încărcarea Studiului: 

• Navigați la colecția Studies → folderul de studiu alocat (Ex: Line1 StudyFolder) → 

model kinematics folder. 

• Executați Click-dreapta pe studiul model kin demos și alegeți Check Out, apoi OK. 

• Executați Click-dreapta pe studiul model kin demos și alegeți Load in Standard 

Mode. 
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5. Izolarea Dispozitivului: 

• Comutați la vizualizatorul Object Tree. Navigați la folderul Resources. 

• Executați Click-dreapta pe obiectul room_door_demo și alegeți Display Only 

(Afișare Doar). 

• Alegeți View → Zoom to Fit pentru a încadra ușa pe ecran. 

• Faceți clic în spațiul liber din Graphic Viewer pentru a deselecta ușa. 



Bazele simulării robotice și analiza cinematică în Process Simulate 

146 

 

 

Workflow: Acționarea manuală a articulațiilor (Joint Jog) 

1. Accesarea Instrumentului Joint Jog: 

• Setați Pick Level la Component. 

• Selectați obiectul room_door_demo în Graphic Viewer. 

• Alegeți Kinematics → Joint Jog (Cinematică → Deplasare Articulație). 

• Rezultat: Se deschide dialogul Joint Jog - room_door_demo, care listează 

articulațiile dispozitivului (j1, j2). 
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2. Metoda 1: Jogging Interactiv: 

• În dialogul Joint Jog, faceți clic pe gear (simbolul roții dințate) asociat articulației j1 

și mențineți butonul mouse-ului apăsat. 

• Mișcați mouse-ul stânga-dreapta peste Graphic Viewer. 

• Observație: Ușa se mișcă în timp real pe măsură ce articulația j1 (rotația ușii) se 

schimbă. Eliberați butonul. 

• Repetați pentru articulația j2 (rotația mânerului). 
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• Notă: Când articulațiile ating limitele de lucru (working limits), cursorul și câmpul 

Value devin de culoare light purple, iar la atingerea limitelor absolute devin dark 

purple. 

 

 

3. Metoda 2: Jogging Incremental (Pas cu Pas): 

• În dialogul Joint Jog, faceți clic pe pictograma Options (Opțiuni). 

• În dialogul Joint Jog Settings, introduceți mărimea pasului (step size) pentru: 

• Prismatic joints step size: (Ex: 10.000 mm). 

• Revolute joints step size: (Ex: 15.00 deg). 
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• Faceți clic pe OK. 

• Folosiți butoanele săgeți (sus/jos) de lângă câmpul Value al articulației j1 pentru a o 

mișca în pași de 15 grade. 

 

 

Instrumentul Joint Jog este metoda fundamentală de manipulare directă a dispozitivelor cinematice. 

Acesta permite utilizatorului să testeze limitele, să înțeleagă mișcarea și să obțină poziții articulare 

specifice necesare pentru definirea operațiilor. 



Bazele simulării robotice și analiza cinematică în Process Simulate 

150 

 

 

4.2. INTRODUCERE ÎN OPERAȚIILE DE DISPOZITIV 

 

4.2.1. Definirea Pozițiilor Cinematice 

Obiectiv: Definirea și salvarea pozițiilor articulare cheie (Poses) pentru dispozitivul cinematic al ușii, 

utilizând Pose Editor și actualizarea bazei de date eMServer. 

O Poziție (Pose) este o configurație salvată a valorilor articulațiilor unui dispozitiv (Ex: j1=90 deg, 

j2=0 deg). Pozițiile sunt folosite ulterior ca puncte de referință în operațiile de dispozitiv (Device 

Operations) pentru a comanda mișcarea automată (Ex: ușa se deplasează de la poziția CLOSED la 

OPEN). 

Workflow: Setarea Unităților (Verificare) 

1. Accesarea Opțiunilor: 

• Executați Click-dreapta într-o zonă goală din Graphic Viewer și selectați Options. 

2. Verificarea Unităților: 

• Navigați la fila Units (Unități). 

• Asigurați-vă că unitatea Linear este setată la mm și Angular la deg. 

• Faceți clic pe OK. 

 

Workflow: Crearea Poziției HOME și CLOSED 

1. Revenirea la Poziția de Bază (HOME): 

• Executați Click-dreapta pe obiectul room_door_demo în Graphic Viewer și alegeți 

Home. 
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• Observație: Aceasta este poziția HOME, definită implicit ca j1=0 și j2=0 la crearea 

cinematicii. 

 

2. Deschiderea Pose Editor: 

• Executați Click-dreapta pe room_door_demo și alegeți Pose Editor. 

3. Crearea Poziției CLOSED: 

• În dialogul Pose Editor, faceți clic pe New (Nou). 

• Lăsați valorile articulațiilor la 0.00 (aceeași poziție ca HOME). 

• În câmpul Pose name, introduceți CLOSED. 

• Faceți clic pe OK. 
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Workflow: Crearea Poziției OPEN 

1. Crearea unei Noi Poziții: 

• În Pose Editor, faceți clic pe New (Nou). 

2. Jogging la Poziția Dorită: 
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• În dialogul Edit Pose, utilizați cursorul (sau săgețile de pas) pentru articulația j1 pentru 

a o mișca (Ex: la o valoare pozitivă, cum ar fi 90.00 deg) până când ușa ajunge într-o 

poziție deschisă. 

• (Opțional) Reglați j2 (mânerul). 

3. Salvarea Poziției OPEN: 

• În câmpul Pose name, introduceți OPEN. 

• Faceți clic pe OK. 

 

Workflow: Testarea și Salvarea Pozițiilor 

1. Comutarea Între Poziții: 

• În dialogul Pose Editor, selectați poziția CLOSED. 

• Faceți clic pe Jump (Salt). Ușa se va închide. 

• Selectați poziția OPEN și faceți clic pe Jump. Ușa se va deschide. 

2. Revenirea la HOME: 

• Faceți clic pe Reset în Pose Editor pentru a reveni la poziția inițială (HOME: j1=0, 

j2=0). 
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3. Actualizarea Bazei de Date: 

• Alegeți File → eM Server Selective Update (Actualizare Selectivă eM Server). 

• În dialog, bifați casetele Resources și Operations (Operațiile). 

• Observație: Pozițiile create sunt atribute ale dispozitivului (Resource), deci bifarea 

Resources este esențială pentru a salva noile poziții în baza de date eMS. 

• Faceți clic pe OK, apoi OK din nou pentru a confirma exportul. 

 

Definirea de Poses este un mecanism standard de programare a dispozitivelor. Prin salvarea 

configurațiilor articulare cheie, utilizatorul poate crea ulterior operații automate clare, care mută 

dispozitivul direct între stări discrete, cum ar fi CLOSED și OPEN. 
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4.2.2. Crearea unei Operații Simulative din Poziții 

Obiectiv: Crearea unei operații de dispozitiv (Device Operation) pentru a simula mișcarea ușii între 

pozițiile salvate (CLOSED și OPEN). 

Device Operation este tipul de operație care comandă mișcarea unui dispozitiv cinematic (non-robot) 

între două poziții (From Pose și To Pose). Aceste operații sunt agregate în operații compuse 

(Compound Operations) care definesc secvența de simulare. 

Workflow: Crearea Operației Compuse Părinte 

1. Selectarea Vizualizatorului: 

o Selectați vizualizatorul Operation Tree. 

2. Crearea Operației Compuse (Container): 

o Alegeți Operations → New Operation → New Compound Operation. 

o În dialogul New Compound Operation: 

▪ Pentru Name, introduceți MyOperations. 

▪ Pentru Scope, selectați Operation Root din lista derulantă. 

o Faceți clic pe OK. 

o Rezultat: Noua operație compusă MyOperations este adăugată la rădăcina arborelui 

de operații. 

 

Workflow: Crearea Operației de Dispozitiv (Device Operation) 

1. Pregătirea Selecției: 

o În Operation Tree, selectați operația MyOperations (CompoundOperation). 

o Țineți apăsată tasta [Ctrl]. 

o Selectați dispozitivul room_door_demo din Graphic Viewer. 

o Eliberați tasta [Ctrl]. 
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2. Crearea Operației de Dispozitiv: 

o Alegeți Operations → New Operation → New Device Operation. 

o Observație: Câmpurile Name și Device din dialog sunt completate automat 

(room_door_demo_Op și room_door_demo). Scope este setat la MyOperations. 

3. Definirea Pozițiilor de Start/Stop: 

o Din lista derulantă From pose, selectați poziția CLOSED. 

o Din lista derulantă To pose, selectați poziția OPEN. 

o Faceți clic pe OK. 

o Rezultat: Operația room_door_demo_Op este adăugată sub MyOperations în 

Operation Tree și în Sequence Editor. 

 

Workflow: Rularea și Resetarea Simulare 

1. Vizualizarea Secvenței: 

o Asigurați-vă că vizualizatorul Sequence Editor (Editorul de Secvență) este vizibil. 
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2. Reset Deep (Salt la Sfârșit): 

o Din Sequence Editor, faceți clic pe pictograma Jump Simulation to End (Salt la 

Sfârșitul Simulare). 

3. Resetare (Salt la Start): 

o Faceți clic pe pictograma Jump Simulation to Start (Salt la Începutul Simulare). 

4. Rularea Simulare: 

o Faceți clic pe pictograma Play Simulation Forward (Rulează Simulare Înainte). 

o Observație: Ușa se mișcă de la starea CLOSED la OPEN. 

o Notă: Viteza simulării poate fi ajustată prin: 1) modificarea timpului alocat operației, 

2) modificarea vitezei articulațiilor definite, sau 3) ajustarea Simulation Time 

Interval (Intervalul de Timp al Simulare). 

5. Resetare: 

o Faceți clic pe Jump Simulation to Start după rulare. 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

158 

 

 

Crearea operațiilor de dispozitiv permite simularea precisă a comportamentului mecanic al utilajelor. 

Prin încapsularea mișcării în operații, utilizatorul obține un control clar și secvențial asupra fluxului 

procesului în Sequence Editor. 

 

4.3. UTILIZAREA CINEMATICII INVERSE 

 

4.3.1. Examinarea Arborelui Cinematic al unui Robot 

Obiectiv: Vizualizarea și înțelegerea structurii cinematice a unui robot utilizând Kinematics Editor 

și corelarea culorilor legăturilor (links) din editor cu modelul 3D. 

Cinematica Inversă (IK) este procesul prin care Process Simulate calculează valorile articulațiilor 

unui robot necesare pentru a poziționa și orienta vârful său (TCP - Tool Center Point) într-o locație 

specifică în spațiul 3D. Kinematics Editor (Editorul de Cinematică) oferă o reprezentare grafică a 

modului în care sunt definite legăturile (Links) și articulațiile (Joints) robotului. 

Workflow: Încărcarea și Izolarea Robotului 

1. Verificarea Stării: 

o Asigurați-vă că studiul model kin demos este încărcat și că Pick Level este setat la 

Component. 

2. Izolarea Robotului: 

o Utilizați funcția de căutare (Edit → Find) sau Object Tree pentru a localiza obiectul 

real_robot în folderul Resources. 

o Executați Click-dreapta pe real_robot și alegeți Display Only. 

o Alegeți View → Zoom to Fit. 
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Workflow: Vizualizarea în Kinematics Editor 

1. Deschiderea Editorului: 

o Selectați robotul în Graphic Viewer (sau Object Tree). 

o Alegeți Kinematics → Kinematics Editor. 

o Rezultat: Se deschide dialogul Kinematics Editor - real_robot, care afișează 

arborele cinematic al robotului, cu noduri reprezentând legăturile și săgeți etichetate 

reprezentând articulațiile. 
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2. Corelarea Culorilor: 

o Observație: Legăturile (links) robotului din Graphic Viewer sunt colorate temporar 

în funcție de culorile nodurilor din Kinematics Editor. Aceasta ajută la identificarea 

vizuală a fiecărui element cinematic (Ex: nodul Kbase corespunde bazei robotului). 

 

3. Închiderea: 

o Faceți clic pe Close (Închide) în dialogul Kinematics Editor. 

o Notă: Crearea și editarea cinematicii robotului sunt subiecte mai avansate și vor fi 

acoperite în capitole ulterioare. 

Kinematics Editor este o fereastră esențială pentru diagnosticarea și validarea definiției unui robot. 

Înțelegerea structurii legăturilor și articulațiilor este baza pentru depanarea problemelor de mișcare și 

pentru programarea eficientă bazată pe cinematica inversă. 
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5. INSTRUMENTE DE ANALIZĂ ȘI DATE DE STUDIU ÎN PROCESS 

SIMULATE 

 

 

Acest capitol se concentrează pe instrumentele auxiliare de analiză și documentare din Process 

Simulate. Aceste funcții (Snapshots, Markup Editor, Notes) sunt esențiale pentru capturarea stărilor 

cheie ale simulării, pentru comunicarea problemelor de layout și pentru adnotarea eficientă a 

modelului 3D. 

 

5.1.CREAREA ȘI UTILIZAREA SNAPSHOTS 

 

Un Snapshot (Instantaneu) este o salvare a stării curente a vizualizării 3D. Acesta poate stoca nu doar 

punctul de vedere, ci și vizibilitatea obiectelor, locațiile, pozițiile dispozitivelor și alte atribute. 

Snapshots sunt folosite pentru navigarea rapidă între scene de interes sau pentru documentare. 

 

5.1.1. Crearea de Capturi Instantanee (Snapshots) 

Obiectiv: Crearea, redenumirea și utilizarea instantaneelor în Snapshot Editor. 

Workflow: Crearea unei Operații de Flux (Dacă este Necesară) 

Acești pași sunt necesari doar dacă nu există nicio operație simulative activă în studiu. 

1. Selecția Obiectelor: 

o Selectați un obiect în Graphic Viewer (Ex: Platform). 

o Țineți apăsată tasta [Ctrl] și selectați o operație compusă (container) în Operation 

Tree (Ex: Room 100). 
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2. Crearea Operației de Flux: 

o Alegeți Operations → New Operation → New Object Flow Operation. 

o Observație: Câmpurile Name (Ex: Platform_Op) și Object (Platform) sunt 

completate. 

3. Definirea Traseului: 

o În dialogul New Object Flow Operation, faceți clic în caseta End Point (Punct 

Final). 

o Selectați un punct pe podea (floor) în Graphic Viewer pentru a defini destinația 

traseului. 
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o Faceți clic pe OK. 

 

Workflow: Crearea și Redenumirea Snapshots 

1. Deschiderea Snapshot Editor: 

o Alegeți View → Viewers → Snapshot Editor. 

o Asigurați-vă că vizualizatorul este extins pentru a vedea toate pictogramele. 

2. Crearea Primului Snapshot: 

o Faceți clic pe pictograma New Snapshot (Instantaneu Nou). 

o Rezultat: Un nou snapshot (Snapshot#) este creat, capturând scena 3D curentă. 

3. Redenumirea: 

o Selectați numele snapshot-ului nou creat și apăsați tasta [F2] sau faceți clic pe 

pictograma Edit Snapshot. 

o Redenumiți-l (Ex: Zoomed View). 
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4. Crearea unui Al Doilea Snapshot: 

o Modificați vederea în Graphic Viewer (rotiți, faceți zoom, blank sau display câteva 

obiecte). 

o Creați un al doilea snapshot și numiți-l (Ex: Another View). 
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Workflow: Utilizarea și Sortarea Snapshots 

1. Aplicarea Snapshots: 

o Double-click pe snapshot-ul Zoomed View. 

o Rezultat: Vederea 3D revine la punctul de vedere salvat (dar nu neapărat și la starea 

de vizibilitate a obiectelor). 

o Repetați pentru snapshot-ul Another View. 

2. Configurarea Atributelor Aplicabile: 

o Faceți clic pe săgeata derulantă Apply Snapshot (Aplică Instantaneu). 

o Observație: Lista afișează atributele care pot fi aplicate: Point of View (Punct de 

Vedere), Objects Visibility (Vizibilitate Obiecte), Objects Locations (Locații 

Obiecte), Device Poses (Poziții Dispozitive), Objects Attachments (Atașamente 

Obiecte), Objects Colors, Objects Viewing Mode, PMI Text Size. 

o Puteți bifa una sau mai multe opțiuni pentru a defini ce se restabilește la aplicarea 

snapshot-ului. 

3. Sortarea: 

o În panoul superior al Snapshot Editor, executați Click-dreapta și alegeți Sort 

Snapshots. 

o Rezultat: Snapshots sunt rearanjate în ordine alfabetică sau cronologică. 
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Snapshots reprezintă un instrument de documentare și navigare extrem de eficient. Ele îmbunătățesc 

colaborarea, permițând echipei să se refere rapid la stări de simulare specifice și să standardizeze 

punctele de inspecție vizuală. 

 

5.2.UTILIZAREA MARKUP EDITOR 

 

Markup Editor (Editorul de Adnotări) permite utilizatorilor să adauge note, text și desene libere 

(scribbles) peste o imagine capturată din Graphic Viewer. Acesta este ideal pentru a evidenția zone 

problematice, a adăuga instrucțiuni sau a comenta rezultatele simulării. 

 

5.2.1. Crearea de Adnotări 

Obiectiv: Utilizarea funcțiilor de adnotare din Markup Editor și salvarea imaginii rezultate. 

Workflow: Adăugarea de Adnotări (Markups) 

1. Deschiderea Markup Editor: 

o Alegeți File → Outputs → Markup Editor. 

2. Adăugarea unei Note (Add Note): 

o Din bara de instrumente Markup Editor, faceți clic pe pictograma Add Note (Adaugă 

Notă). 

o Faceți clic pe o zonă din imaginea capturată. 

o În dialogul Edit Text, setați dimensiunea fontului (Ex: 36). 

o Tastați textul dorit (Ex: Look at this exciting note!). 
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o Faceți clic pe OK. 

o Trageți de mânerele notei pentru a o redimensiona, astfel încât textul să fie vizibil. 

3. Adăugarea de Text (New Text): 

o Faceți clic pe pictograma New Text (ABC). 

o Faceți clic pe o altă zonă a imaginii. 

o Tastați text suplimentar (Ex: This is so fun). 

o Redimensionați caseta de text. 

4. Adăugarea unui Desen Liber (Scribble): 

o Faceți clic pe pictograma New Scribble Polygon (Poligon de Desen Liber). 

o Desenați un cerc sau o formă liberă în jurul unui obiect din imagine. 
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Workflow: Salvarea și Închiderea 

1. Salvarea Fiecării: 

o Din dialogul Markup Editor, alegeți pictograma Save as File (Salvează ca Fișier). 

o Navigați la directorul de salvare dorit (Ex: C:\Temp). 

o Introduceți un nume de fișier (Ex: Markup_image_user1). 

o Faceți clic pe Save. 

2. Închiderea: 

o Faceți clic pe Close (Închide) în dialogul Markup Editor. 

Markup Editor este un instrument puternic de comunicare care transformă o simplă captură de ecran 

într-un document analitic, permițând inginerilor să semnaleze rapid problemele de design sau de 

proces către părțile interesate. 

 

5.3.ADĂUGAREA DE TEXT ÎN GRAPHIC VIEWER (NOTES ȘI LABELS) 

 

Notes (Note) și Labels (Etichete) sunt entități 3D stocate direct în studiul Process Simulate. Ele sunt 

utilizate pentru a adăuga informații persistente care plutesc în spațiul 3D, fiind ideale pentru a marca 

instrucțiuni de asamblare sau pentru a evidenția zone critice. 

 

5.3.1. Setarea Opțiunilor pentru Note 

Obiectiv: Modificarea aspectului grafic (culori de fundal, text, bordură) al notelor nou create. 

Workflow: Schimbarea Culorii de Fundal 



Bazele simulării robotice și analiza cinematică în Process Simulate 

169 

 

1. Accesarea Opțiunilor: 

o Alegeți Tools → Options. 

2. Navigare la Aspect: 

o Faceți clic pe fila Appearance (Aspect). 

3. Setarea Culorii de Fundal 3D: 

o În lista superioară, selectați Background sub Graphic Viewer. 

o În lista inferioară, selectați Solid (în loc de Vertical). 

o Schimbați culoarea de fundal (Ex: la un light brown). 

o Faceți clic pe Preview și apoi OK (sau continuați cu următorii pași). 

 



Bazele simulării robotice și analiza cinematică în Process Simulate 

170 

 

Workflow: Modificarea Culorilor Notelor 

1. Navigare la Obiecte Noi: 

o Rămânând în fila Appearance, navigați la secțiunea New Objects (Obiecte Noi) din 

lista superioară. 

2. Setarea Culorii Fundalului Notei: 

o Selectați Note Background din listă. 

o Schimbați culoarea (Ex: la Albastru). 

3. Setarea Culorii Bordurii Notei: 

o Selectați Note Border din listă. 

o Schimbați culoarea (Ex: la Roșu). 

4. Setarea Culorii Textului Notei: 

o Selectați Note Text din listă. 

o Schimbați culoarea (Ex: la Alb). 

o Observație: Aceste modificări vor fi aplicate tuturor Notes create ulterior aplicării 

opțiunilor. 

5. Finalizarea: 

o Faceți clic pe OK. 

Personalizarea culorilor pentru Notes asigură că adnotările 3D se integrează sau, dimpotrivă, se 

evidențiază în scena de simulare. Acestea oferă un mijloc de comunicare directă și persistentă a 

informațiilor critice în modelul 3D. 

Acest conținut încheie Capitolul 5, acoperind integral activitățile din materialul atașat, conform 

cerințelor de structură, ton și limbaj. 

5.3.2. Crearea de Note în Graphic Viewer 

Obiectiv: Crearea, editarea și manipularea notelor (Notes) și etichetelor (Labels) în spațiul 3D al 

simulării. 

Introducere 

Notes și Labels oferă o modalitate de a atașa informații textuale direct în Graphic Viewer. Notele 

sunt de obicei asociate studiului, în timp ce etichetele sunt asociate obiectului, dar ambele sunt 

esențiale pentru documentarea vizuală a procesului. 

Workflow: Crearea de Note Multi-Obiecte 

1. Selecția Obiectelor: 

o În Graphic Viewer, desenați o fereastră de selecție (boxă) în jurul zonei dorite pentru 

a selecta mai multe obiecte (Ex: echipamentele dintr-o celulă). 
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2. Crearea Notelor pe Obiecte: 

o Alegeți Tools → Notes → Object Notes (Instrumente → Note → Note Obiect). 

o Rezultat: Pentru fiecare obiect selectat, o notă separată, ce afișează numele obiectului, 

este creată și atașată obiectului. 

 

3. Poziționarea: 

o Trageți și plasați notele în Graphic Viewer într-o poziție vizuală convenabilă. 
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4. Gestionarea Notelor: 

o Vizualizați notele nou create în folderul Notes din Object Tree. De aici, ele pot fi 

ascunse (blanked), afișate sau șterse. 

o Notă: Notes (Note) sunt considerate study data (date de studiu), la fel ca dimensiunile 

și cadrele, fiind stocate în studiu și nu în arborele de produs/operație/resursă. 

 

Workflow: Crearea de Note Textuale Simple (Create Note) 

1. Activarea Comenzii: 

o Selectați o locație în Graphic Viewer unde doriți să plasați nota. 

o Alegeți Tools → Notes → Create Note (sau faceți clic pe pictograma corespunzătoare 

de pe bara de instrumente). 

2. Editarea Conținutului: 

o În dialogul Note Editor, introduceți textul dorit în zona Text. 
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o Faceți clic pe OK. 

Workflow: Editarea și Modificarea Vizuală a unei Note 

1. Editarea Textului și a Punctului de Ancorare: 

o Selectați o notă creată anterior. 

o Alegeți Tools → Notes → Edit Note (Editează Notă). 

o În dialogul de editare, schimbați textul în caseta Text. 

o Faceți clic în caseta Object și selectați un nou punct de ancorare (anchor point) pe 

un obiect în Graphic Viewer pentru linia de legătură (leader line). 

o Faceți clic pe OK. 

2. Toggle Display (Comutare Afișare): 

o Selectați nota (sau un grup de note). 

o Alegeți Tools → Notes → Toggle Note Visibility (Comută Vizibilitatea Notei). 

o Rezultat: Nota comută între afișarea textului integral și afișarea unui flag 

(steag/indicator) simplu. 

o Repetați comanda pentru a comuta înapoi la afișarea textului. 

3. Schimbarea Culorii (Note Existente): 

o Executați Click-dreapta pe o notă și alegeți Modify Color (Modificare Culoare). 

o Selectați o culoare nouă. (Aceasta suprascrie setările implicite, spre deosebire de 

setările din Tools → Options care afectează doar notele noi). 

4. Mutarea: 

o Trageți și plasați nota în poziția dorită. 

Workflow: Crearea de Etichete (Labels) 

1. Crearea Etichetei: 

o Selectați un obiect în Graphic Viewer. 

o Alegeți Tools → Labels → Create Label (Instrumente → Etichete → Crează 

Etichetă). 

o Faceți clic pe OK în dialogul de creare. 

2. Diferența dintre Note și Etichete: 

o Trageți eticheta în poziția dorită. 

o Zoom In și Zoom Out în Graphic Viewer. 
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o Observație: Notele mențin o dimensiune de font fixă pe ecran (dacă este bifată 

opțiunea Keep size while changing zoom în Edit Note), în timp ce etichetele sunt 

asociate obiectului și pot avea un comportament vizual diferit la zoom. 

o Diferența Cheie: Labels (Etichetele) sunt asociate și salvate cu obiectul în baza de 

date (part/resource), în timp ce Notes (Notele) sunt asociate și salvate cu studiul. 

Notes și Labels sunt instrumente fundamentale pentru documentarea permanentă în modelul 3D. 

Înțelegerea diferenței dintre notele asociate studiului și etichetele asociate obiectului este crucială 

pentru a asigura că informația este stocată și transmisă corect în mediul eMS. 

 

5.3.3. Crearea de Dimensiuni în Graphic Viewer 

Obiectiv: Utilizarea instrumentelor de măsură pentru a crea dimensiuni permanente (Dimensions) în 

studiul 3D. 

Dimensions (Dimensiuni) sunt reprezentări grafice persistente ale distanțelor măsurate, utile pentru 

verificarea spațiului și documentarea layout-ului. 

Workflow: Adăugarea unei Dimensiuni Punct-la-Punct 

1. Activarea Comenzii: 

o Alegeți Tools → Measurements → Create Dimension → Point to Point Dimension 

(Instrumente → Măsurători → Crează Dimensiune → Dimensiune Punct-la-Punct). 

2. Selecția Punctelor: 

o Selectați două puncte consecutive în Graphic Viewer (Ex: două colțuri ale unui 

obiect). 

3. Poziționarea: 

o Trageți dimensiunea pentru a o poziționa în spațiul 3D. 

o Rezultat: Distanța este acum o entitate grafică permanentă în studiu și este stocată în 

folderul Dimensions din Object Tree. 

Workflow: Integrarea Dimensiunilor în Documentație (Markup) 

1. Crearea unei Adnotări (Markup): 

o Alegeți File → Outputs → Markup Editor. 

2. Vizualizarea: 

o Observație: Notele și dimensiunile create anterior sunt afișate în Markup Editor, 

putând fi salvate ca imagine de documentație. 

3. Închiderea: 

o Închideți dialogul Markup Editor. 
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Adăugarea de Dimensions la un studiu Process Simulate transformă rezultatele măsurătorilor în 

documentație vizuală persistentă, îmbunătățind acuratețea și claritatea rapoartelor de validare. 

 

5.4.STOCAREA IMAGINILOR STUDIULUI 

 

Exportul imaginilor de înaltă calitate din Graphic Viewer este esențial pentru rapoarte, prezentări și 

comunicarea rezultatelor simulării. Process Simulate oferă opțiuni clare pentru controlul fundalului 

și formatul de export. 

 

5.4.1. Exportarea Graphic Viewer într-un Fișier sau Imprimantă 

Obiectiv: Setarea culorii de fundal pentru exportul curat al imaginii și salvarea vizualizatorului într-

un fișier grafic. 

Workflow: Setarea Culorii de Fundal (Pentru Export) 

1. Accesarea Opțiunilor: 

o Alegeți Tools → Options. 

2. Navigare la Aspect: 

o Faceți clic pe fila Appearance (Aspect). 

3. Setarea Culorii: 

o În lista superioară, selectați Background sub Graphic Viewer. 

o Din lista derulantă inferioară, selectați Solid. 

o Schimbați culoarea la Alb (White) pentru a obține o imagine curată, potrivită pentru 

tipărire (deși Alb poate fi setat ca opțiune de fundal la export, setarea alb în mediul de 

lucru ajută la vizualizarea în timpul exportului). 

o Faceți clic pe OK. 

Workflow: Exportul Imaginii 

1. Activarea Exportului: 

o Alegeți File → Import/Export → Export Images. 

2. Selectarea Formatului și a Locației: 

o În dialogul Export Cell, selectați formatul de fișier dorit din lista derulantă Save as 

type (Ex: BMP, JPG, .png sau TIFF). 

o Navigați la directorul de ieșire (Ex: C:\temp sau Desktop). 

3. Denumirea Fișierului: 
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o Tastați un nume de fișier care include ID-ul utilizatorului (Ex: 

Simulare_Finala_user1). 

4. Salvarea: 

o Faceți clic pe Save (Salvează). 

5. Revenirea la Fundalul Standard: 

o După salvare, reveniți la Tools → Options → Appearance → Background și 

schimbați culoarea de fundal înapoi la culoarea de lucru preferată (Ex: Albastru sau 

Negru). 

Exportul imaginilor este un pas esențial în ciclul de documentare. Setarea fundalului la Alb înainte 

de export asigură o imagine de raport curată, iar funcția de export permite salvarea în formate standard 

pentru diseminare ulterioară. 

 

5.5. DETECȚIA COLIZIUNILOR  

 

Detecția coliziunilor este o funcție esențială în Process Simulate, utilizată pentru a valida siguranța și 

fezabilitatea mișcărilor robotice sau a dispozitivelor. Coliziunile (Collisions) (evidențiate cu roșu) și 

aproape-coliziunile (Near Misses) (evidențiate cu galben) sunt detectate între perechi de liste de 

obiecte predefinite (Collision Sets). 

5.5.1. Collision Viewer și Seturi de Coliziune Rapide 

Obiectiv: Activarea Collision Viewer și utilizarea Fast Collision pentru a testa rapid o configurație 

de coliziune generală. 

Workflow: Activarea Collision Viewer 

1. Afișarea Vizualizatorului: 

o Dacă nu este vizibil, alegeți View → Viewers → Collision Viewer. 

o Andocați vizualizatorul în partea de jos a ecranului și Pinați-l (fixați-l) pentru a-l 

menține extins. 

2. Afișarea Seturilor de Coliziune: 

o În Collision Viewer, faceți clic pe pictograma Show/Hide Collision Sets pentru a 

afișa panoul din stânga. 

Workflow: Setarea Fast Collision 

1. Selecția Obiectelor: 

o Din bara de instrumente Selection, activați Select with Filter. 

o Setați tipul de selecție la Selection Type Parts și apoi la Selection Type Resources. 

(Puteți folosi și Selection Type All). 
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o Observație: Obiectele selectate sunt evidențiate în Graphic Viewer. 

2. Crearea Setului Rapid: 

o Din bara de instrumente Collision Viewer, faceți clic pe Fast Collision. 

o Rezultat: Un nou set numit fast_collision_set este creat în panoul din stânga, 

incluzând obiectele selectate. 

3. Activarea Detecției: 

o Asigurați-vă că fast_collision_set este bifat în panoul din stânga. 

o Faceți clic pe pictograma Collision Mode On/Off de pe bara de instrumente pentru a 

porni verificarea coliziunilor. 

 

Workflow: Testarea și Raportarea Coliziunilor 

1. Provocarea unei Coliziuni: 

o Utilizați Fast Placement sau Placement Manipulator pentru a muta un obiect dintr-

o listă astfel încât să se suprapună cu un obiect din lista celuilalt set. 

o Observație: Obiectele care se ciocnesc sunt evidențiate instantaneu în roșu. 

2. Examinarea Raportului: 

o Collision Viewer afișează perechile de obiecte aflate în coliziune (Collision, culoare 

roșie) sau în aproape-coliziune (Near Miss, culoare galbenă). 

o Extindeți un obiect din listă pentru a vedea cu ce obiecte se ciocnește. 

3. Dezactivarea Setului: 

o În panoul din stânga al Collision Viewer, debifați caseta de lângă fast_collision_set 

pentru a opri verificarea pentru acest set. 
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5.5.2. Definirea Seturilor de Coliziune 

Obiectiv: Crearea manuală a unor seturi de coliziune definite de utilizator (Collision Sets) prin 

specificarea explicită a perechilor de obiecte de verificat. 

Introducere 

Detecția coliziunilor funcționează prin verificarea intersecției geometrice între obiectele dintr-o primă 

listă (Check) și obiectele dintr-o a doua listă (With). 

Workflow: Crearea unui Nou Set de Coliziune 

1. Inițierea: 

o În Collision Viewer, faceți clic pe pictograma New Collision Set (Set Nou de 

Coliziune). 
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2. Definirea Listei Check: 

o În dialogul Collision Set Editor, faceți clic în zona Check. 

o Selectați obiectele dorite pentru prima listă în Graphic Viewer (Ex: 

room_door_demo). 

3. Definirea Listei With: 

o Faceți clic în zona With. 

o Selectați obiectele dorite pentru a doua listă (Ex: real_robot). 

o Faceți clic pe OK. 

4. Redenumirea: 

o În panoul din stânga al Collision Viewer, selectați noul set (Ex: new_collision_set) și 

apăsați [F2]. 

o Redenumiți-l (Ex: MyFirstList). 

Workflow: Verificarea Vizuală a Setului (Emphasize) 

1. Selectarea Setului: 

o Selectați MyFirstList în Collision Viewer. 

2. Evidențierea: 

o Faceți clic pe pictograma Emphasize Collision Set (Evidențiază Setul de Coliziune). 

o Observație: Obiectele din lista Check sunt colorate într-o nuanță (Ex: Albastru), iar 

obiectele din lista With sunt colorate în alta (Ex: Galben), permițând verificarea 

vizuală a setului. 
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3. Editarea Setului: 

o Faceți clic pe pictograma Edit Collision Sets (Editează Seturile de Coliziune). 

o Adăugați sau eliminați obiecte, apoi apăsați OK și faceți clic din nou pe Emphasize 

Collision Set pentru a vedea efectul. 
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Seturile de coliziune definite de utilizator oferă control precis asupra analizei de interferență. Prin 

definirea perechilor de liste, inginerii pot optimiza performanța simulării, concentrându-se doar pe 

interacțiunile critice (Ex: unelte cu piese, robot cu structura celulei). 

 

5.5.3. Setarea Coliziunilor și Collision Viewer 

Obiectiv: Configurarea opțiunilor de coliziune (Near-Miss, sunet, oprire simulare) și testarea 

funcționalității Collision Viewer într-un scenariu de Fast Collision. 

Setările de coliziune definesc sensibilitatea sistemului (Near-Miss Value) și comportamentul său la 

detectarea unei coliziuni (oprire, sunet). Acestea sunt esențiale pentru a personaliza analiza de risc. 
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Workflow: Configurarea Opțiunilor de Coliziune 

1. Accesarea Opțiunilor: 

o Faceți clic pe pictograma Collision Options din Collision Viewer (sau Tools → 

Options → Collision). 

2. Setarea Pragului Near-Miss: 

o Bifați Check for Collision Near-Miss (Verifică Aproape-Coliziunile). 

o Introduceți valoarea dorită pentru Near-Miss Default Value (Ex: 50 mm). 

3. Configurarea Comportamentului: 

o Debifați (sau lăsați debifate) opțiunile Stop Simulation when a Collision is Detected 

(Oprește Simulare la Coliziune). 

o Debifați (sau lăsați debifate) opțiunile Play Sound when a Collision is Detected 

(Redă Sunet la Coliziune). 

o (Opțional) Sub Collision Sound File to Play, faceți clic pe Browse și selectați un 

fișier .wav din directorul de efecte sonore (Ex: \sound effects folder). 

4. Finalizare: 

o Faceți clic pe OK. 
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Workflow: Testarea cu Collision Viewer 

1. Activarea Coliziunilor: 

o Asigurați-vă că detecția coliziunilor este pornită (Collision Mode On/Off) și că un set 

de coliziune (Ex: fast_collision_set sau un set definit de utilizator) este bifat în panoul 

din stânga. 

2. Provocarea Coliziunii: 

o Utilizați Placement Manipulator pentru a deplasa intenționat un obiect (Ex: robotul) 

în suprapunere cu un alt obiect (Ex: ușa sau structura). 

o Observație: Obiectele care se suprapun se colorează în roșu. 
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3. Examinarea Raportului: 

o Collision Viewer afișează imediat în panoul din dreapta lista perechilor care se 

ciocnesc (List Colliding Pairs), inclusiv starea coliziunii (Collision Status) și 

distanța (care ar trebui să fie negativă în caz de coliziune). 

4. Extinderea Detaliilor: 

o Extindeți un element din listă pentru a vedea detaliile fiecărei perechi aflate în 

coliziune. 
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Setările de coliziune sunt un pas critic în calibrarea analizei de fezabilitate. Prin ajustarea valorii 

Near-Miss și a modului de raportare, inginerul poate obține alerte timpurii privind interferențele 

potențiale. 

 

5.5.4. Filtrarea Rezultatelor Coliziunii 

Obiectiv: Utilizarea filtrelor și a funcțiilor de vizualizare pentru a izola și a inspecta vizual detaliile 

contururilor de coliziune. 

În scenele complexe cu multe coliziuni, filtrarea și izolarea vizuală a perechilor de coliziune sunt 

esențiale pentru a înțelege exact unde și cum are loc interferența. 
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Workflow: Vizualizarea Selectivă a Coliziunilor 

1. Filtre în Collision Viewer: 

o Faceți clic pe săgeata derulantă de lângă pictograma Filter Collision Results 

(Filtrează Rezultatele Coliziunii). 
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o List All Pairs: Afișează toate perechile de obiecte definite în seturile de coliziune 

(chiar dacă nu se ciocnesc). 

 

o List Colliding Pairs: Limitează lista doar la perechile care se ciocnesc efectiv. 

2. Color Selected Pair (Culoare Pereche Selectată): 

o Faceți clic pe săgeata derulantă de lângă Show Colliding Pair (Afișează Perechea care 

se Ciocnește). 

o Selectați Color Selected Pair. 

o Faceți clic pe un element din lista Collision Viewer. 

o Rezultat: Obiectele din acea pereche se colorează (de obicei în roșu și albastru) în 

Graphic Viewer (toate celelalte obiecte rămân vizibile, dar își pierd culorile inițiale). 
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3. Show Selected Pair Only (Afișează Doar Perechea Selectată): 

o Din meniul derulant Show Colliding Pair, selectați Show Selected Pair Only. 

o Faceți clic pe un element din lista Collision Viewer. 

o Rezultat: Doar cele două obiecte din perechea selectată devin vizibile (toate celelalte 

obiecte sunt ascunse). 
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Workflow: Inspectarea Contururilor de Coliziune (Collision Contours) 

1. Afișarea Conturului: 

o Selectați un element din lista Collision Viewer care indică o coliziune. 

o Faceți clic pe pictograma Show/Hide Colliding Contour (Afișează/Ascunde 

Conturul Coliziunii). 

 

o Rezultat: O curbă (linie) este afișată în Graphic Viewer la intersecția exactă a celor 

două obiecte. 
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2. Zoom la Contur: 

o În panoul Collision Curves (Contururi Coliziune) al Collision Viewer, selectați una 

dintre curbele listate (Ex: floor_a contour001). 

o Faceți clic pe pictograma Zoom to selected (Zoom la Selecție) din acel panou. 

o Rezultat: Vederea 3D se mută și face zoom direct pe zona de interferență, permițând 

o inspecție microscopică. 

 

3. Vizualizarea Conturului după Ascundere (Freeze Viewer): 

o Faceți clic pe pictograma Freeze Viewer (Îngheață Vizualizatorul). 

o Selectați unul dintre obiectele care se ciocnesc și alegeți Blank (Alt+B) pentru a-l 

ascunde. 

o Rezultat: Conturul coliziunii rămâne vizibil pe suprafața obiectului rămas, ceea ce 

este extrem de util pentru a vedea amprenta exactă a interferenței pe un singur obiect. 
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Analiza coliziunilor este o funcție avansată care necesită nu doar detecție, ci și instrumente sofisticate 

de vizualizare. Prin filtrarea, evidențierea și inspectarea Collision Contours, inginerii pot identifica 

și diagnostica cu precizie sursa oricărei probleme de interferență din celula robotică. 

 

5.6.FACTORI CARE AFECTEAZĂ DETECȚIA COLIZIUNILOR  

 

Acuratețea și performanța detecției coliziunilor sunt influențate de mai mulți factori, cel mai critic 

fiind Simulation Time Interval (Intervalul de Timp al Simulare). Deoarece simularea avansează în 

pași discreți de timp, un interval prea mare poate face ca obiectele să "sară" peste un punct de 

coliziune, rezultând o detecție inexactă sau ratată. 

 

5.6.1. Factori care Afectează Detecția Coliziunilor 

Obiectiv: Demonstraraea modului în care Simulation Time Interval și setările de coliziune 

influențează detectarea interferenței geometrice. 

Workflow: Configurarea Inițială a Coliziunilor 

1. Setarea Opțiunilor de Coliziune (Collision Options): 

o Alegeți Tools → Options → Collision. 

o Bifați Stop Simulation when a Collision is Detected (Oprește Simulare la Coliziune). 

o Bifați Play Sound when a Collision is Detected (Redă Sunet la Coliziune). 

o (Opțional) Setați Collision Sound File to Play (Fișier Sunet Coliziune) la un fișier 

.wav. 

o Faceți clic pe OK. 
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2. Definirea Setului de Coliziune: 

o În Collision Viewer, creați un set nou (New Collision Set). 

o Definiți perechea de obiecte care vor intra în coliziune (Ex: ușa cinematică 

room_door_demo în lista Check și un obstacol static real_robot sau un perete în lista 

With). 

o Faceți clic pe OK și activați setul de coliziune. 

3. Activarea Detecției: 

o Asigurați-vă că Collision Mode On/Off este activat. 

 

Workflow: Crearea Scenariului de Coliziune (Device Operation) 

1. Crearea Operației Compuse (Container): 

o În Operation Tree, alegeți Operations → New Operation → New Compound 

Operation. 

o Numiți-o MyOperations și setați Scope la Operation Root. Faceți clic pe OK. 
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2. Crearea Operației de Dispozitiv: 

o Selectați MyOperations. Țineți [Ctrl] apăsat și selectați obiectul room_door_demo în 

Graphic Viewer. 

o Alegeți Operations → New Operation → New Device Operation. 

o Setați From pose la CLOSED și To pose la OPEN. 

o Faceți clic pe OK. 
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Workflow: Rularea Simulare și Efectul Timpului (Time Interval) 

1. Rulare Rapidă (Interval Implicit): 

o Setați Simulation Time Interval la valoarea implicită, de obicei 0.2 secunde: 

▪ În Sequence Editor, faceți clic pe pictograma Set Time Interval. 

▪ Introduceți 0.2 în câmpul Time și OK. 

o Rulați simularea (Play Simulation Forward). 

o Observație: Ușa ar trebui să se miște rapid și, cel mai probabil, va intra în coliziune 

(obiectele se colorează în roșu, simularea se oprește/emite sunet). 
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2. Rulare Foarte Rapidă (Risc de Coliziune Ratată): 

o Setați Simulation Time Interval la o valoare mare (Ex: 1.0 secundă): 

▪ În Sequence Editor, faceți clic pe pictograma Set Time Interval. 
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▪ Introduceți 1.0 în câmpul Time și OK. 

o Rulați simularea. 

o Observație: Coliziunea este ratată. Obiectul se deplasează prea repede între pașii de 

verificare, sărind peste momentul intersecției geometrice. 

o Notă: Acest lucru demonstrează că un interval de timp mare compromite acuratețea 

detecției coliziunilor. 

 

3. Rulare Lentă (Acuratețe Maximă): 

o Setați Simulation Time Interval la o valoare mică (Ex: 0.05 secunde): 

▪ În Sequence Editor, faceți clic pe pictograma Set Time Interval. 

▪ Introduceți 0.05 în câmpul Time și OK. 

o Rulați simularea. 

o Observație: Coliziunea este detectată. Deși rularea este mai lentă, acuratețea 

verificării coliziunilor este maximă. 

4. Revenirea la Valoarea Implicită: 

o Resetați Simulation Time Interval la valoarea implicită (Ex: 0.2 secunde). 

 

Alegerea corectă pentru Simulation Time Interval este un compromis între acuratețea detecției 

coliziunilor și performanța simulării. Pentru simulările critice de coliziune, este necesar un interval 

de timp mic (o frecvență mare de verificare), în timp ce pentru simulările de vizualizare generală se 

poate folosi un interval mai mare. Această înțelegere este esențială pentru a garanta validitatea 

analizelor de fezabilitate. 
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5.7. PLANE DE SECȚIUNE 

 

Planele de secționare (Section Planes) sunt instrumente utilizate pentru a tăia vizual geometria în 

Graphic Viewer, dezvăluind structura internă, interferențele ascunse sau detaliile asamblării. Această 

tehnică este esențială pentru revizii de design și analize de spațiu. 

 

5.7.1. Crearea și Mutarea unui Plan de Secțiune 

Obiectiv: Crearea unui plan de secțiune, manipularea poziției și orientării acestuia folosind Section 

Manager și adăugarea contururilor de secțiune. 

Workflow: Pregătirea Vizualizării și Crearea Planului 

1. Izolarea Obiectelor (Display Only): 

o Selectați obiectele (piese/resurse) pe care doriți să le secționați (Ex: structura unei 

stații) utilizând [Ctrl] + clic sau selecție prin boxare. 

o Executați Click-dreapta pe unul dintre obiectele selectate și alegeți Display Only 

(Afișare Doar). 
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2. Crearea Planului de Secțiune: 

o Alegeți Tools → Sections → New Section Plane (Instrumente → Secțiuni → Plan 

Nou de Secțiune). 

o Observație: Dialogul Section Manager se deschide, iar planul nou (Ex: Section 

plane) este afișat în Graphic Viewer și listat în folderul Sections din Object Tree. 

3. Activarea Tăierii (Cutting): 

o În dialogul Section Manager, faceți clic pe pictograma Activate Section (Activează 

Secțiunea) (sau pe pictograma Cut Section). 

o Rezultat: Secțiunea este tăiată în Graphic Viewer la planul definit. 
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Workflow: Alinierea și Manipularea Planului de Secțiune 

1. Alinierea (Align): 

o În Section Manager, utilizați săgeata derulantă Section Alignment (Aliniere 

Secțiune) pentru a schimba orientarea planului: 

▪ Align to X: Taie secțiunea pe planul YZ al Working Frame. 

▪ Align to Surface: Selectați această opțiune și apoi faceți clic pe o suprafață 

din Graphic Viewer. Planul de secțiune se aliniază tangențial la suprafața 

selectată la punctul respectiv. 
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▪ Align to Point: Menține orientarea curentă, dar mută originea planului la 

punctul selectat. 

 

o Deplasați secțiunea (Ex: alegeți Align to X). 

2. Manipularea Poziției (Translate): 

o În secțiunea Translate a Section Manager, utilizați săgețile Move Negative sau 

Move Positive de lângă axa Z (axa perpendiculară pe planul de tăiere) pentru a muta 

planul de secțiune incremental pe geometria obiectelor. 

o (Opțional) Faceți clic pe link-ul Step size pentru a modifica mărimea pasului de 

translație. 
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3. Performarea Măsurătorilor:  

o Schimbați Pick Intent (Intenția de Selecție) la Where Picked (Unde s-a dat clic). 

o Faceți clic pe Point to Point Distance de pe bara de instrumente. 

o Măsurați distanța dintre două entități vizibile în Section Viewer (dacă este deschis) 

sau pe linia de tăiere din Graphic Viewer. 

 

Workflow: Vizualizarea Avansată a Secțiunii 

1. Afișarea Contururilor: 

o Alegeți Tools → Sections → Show Section Contours (Afișează Contururi Secțiune). 

o Rezultat: O linie (contur) este desenată în Graphic Viewer de-a lungul marginii de 

tăiere. 
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2. Capping și Hatching: 

o Alegeți Tools → Sections → Capping (Acoperire). 

o Rezultat: Suprafețele tăiate ale obiectelor sunt colorate (acoperite), oferind claritate 

asupra geometriei solide. 

o Alegeți Tools → Sections → Hatching (Hașurare). 

o Rezultat: Suprafețele tăiate sunt hașurate cu linii. 

3. Gestionarea Planului: 

o În Object Tree, folderul Sections, planul poate fi ascuns (blanked), afișat, șters sau 

editat prin Click-dreapta → Section Manager. 

o Faceți clic pe Close în dialogul Section Manager pentru a finaliza activitatea. 

Planurile de secțiune sunt instrumente diagnostice esențiale. Ele oferă o perspectivă interioară asupra 

asamblărilor și sunt folosite pentru a confirma că piesele, uneltele și brațele robotice nu interferează 

cu structurile interne, fiind un pas cheie în validarea finală a designului celulei. 

 

5.7.2. Alte aspecte despre Tăierea Secțiunilor  

Obiectiv: Explorarea funcțiilor avansate de vizualizare a secțiunilor, inclusiv deschiderea de 

vizualizatoare dedicate și salvarea contururilor secționate. 

Pe lângă tăierea simplă, Process Simulate permite extragerea contururilor de secțiune ca geometrie 

separată și vizualizarea secțiunilor în ferestre dedicate, esențiale pentru analize detaliate. 

Workflow: Manipularea Vederii Secțiunii 

1. Deschiderea Vizualizatorului Secțiunii (New Section Viewer): 

o În Object Tree, executați Click-dreapta pe un plan de secțiune existent (Ex: Section 

plane) și alegeți New Section Viewer. 

o Rezultat: Se deschide un nou dialog sau fereastră Section Viewer care afișează doar 

clipul de secțiune. 
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2. Activare/Dezactivare Secțiune: 

o Executați Click-dreapta pe planul de secțiune și alegeți Section Manager. 

o În dialogul Section Manager, faceți clic pe Deactivate Section. 

o Observație: Secțiunea dispare din Graphic Viewer principal, dar rămâne vizibilă în 

Section Viewer dedicat. 
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3. Comutarea Clip vs. Cut: 

o Alegeți Tools → Sections → Cut Section (Taie Secțiune). 

o Rezultat: Secțiunea tăiată devine bidimensională (doar planul de tăiere este vizibil). 

4. Orientarea Vederii către Plan: 

o Alegeți Tools → Sections → Orient View to Section Plane (Orientează Vederea către 

Planul de Secțiune). 

o Rezultat: Vederea 3D se aliniază perfect cu planul de secțiune, oferind o perspectivă 

2D precisă a tăieturii. 
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Workflow: Salvarea Conturului de Secțiune 

1. Salvarea Conturului ca Componentă: 

o Selectați conturul de secțiune (prin boxare). 

o Alegeți Tools → Sections → Save Section Contour as Component (Salvează 

Conturul Secțiunii ca și Componentă). 
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o Introduceți un nume de fișier (Ex: C:\temp\SectionComp.cojt). 

o Rezultat: Linia de tăiere este salvată ca o geometrie separată, ce poate fi inserată în 

alte studii sau editată. 

Workflow: Alternative de Tăiere a Secțiunilor 

1. Tăiere la Punct Selectat: Selectați un punct pe un obiect și tăiați secțiunea. Planul de secțiune 

pornește de la acel punct. 

2. Tăiere la Working Frame: Nu selectați nimic, apoi tăiați secțiunea. Tăierea se produce la 

Working Frame și poate fi mutată ulterior. 

3. Tăiere la Originea Obiectului: Setați Pick Intent la Self Origin și Pick Level la 

Component. Selectați un obiect; planul de secțiune va porni de la originea obiectului. 

Workflow: Gestionarea Vizualizatoarelor Secțiunilor (Multiple Viewers) 

1. Crearea Secțiunii: Creați o secțiune de-a lungul planului XY al Working Frame. Deplasați-

o sub toate obiectele și setați modul Cut Section (nu Clip Section). 

2. Deschiderea Vizualizatorului Nou: Deschideți un New Section Viewer pentru secțiunea 

creată. 

3. Aranjarea Ferestrelor: Poziționați noul Graphic Viewer (secțiunea) și Graphic Viewer 

principal (vederea 3D) unul lângă altul. 

4. Gestionarea în Object Tree: 

o Redenumiți secțiunea creată în Object Tree (Ex: View 2). 

o Utilizați Object Tree pentru a ascunde (blank) sau șterge (Delete) secțiunea. 

o Puteți deschide oricând un nou vizualizator dedicat pentru orice secțiune salvată. 

Tehnicile avansate de secționare oferă o metodă non-distructivă de a vizualiza detaliile interne 

complexe. Abilitatea de a salva contururile și de a deschide vizualizatoare dedicate maximizează 

utilitatea Section Planes în analiza geometrică și de layout. 

 

 

5.8.TĂIEREA SECȚIUNILOR CU VOLUME DE SECȚIUNE 

 

Spre deosebire de Section Planes (care taie întregul model pe o singură suprafață), un Section 

Volume (Volum de Secțiune) permite utilizatorului să izoleze sau să ascundă geometria doar în 

interiorul unui volum 3D definit (o cutie). Această metodă este utilă pentru a inspecta o zonă restrânsă 

a celulei. 
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5.8.1. Crearea și Mutarea unui Volum de Secțiune 

Obiectiv: Crearea unui volum prismatic de secțiune, manipularea dimensiunilor și poziției sale, și 

utilizarea modurilor Clip Inside / Clip Outside. 

Workflow: Crearea și Activarea Volumului 

1. Crearea Volumului: 

o Alegeți Tools → Sections → New Section Volume (Instrumente → Secțiuni → 

Volum Nou de Secțiune). 

 

o Rezultat: În Graphic Viewer apare un volum prismatic (de obicei, un cadru de 

sârmă), iar dialogul Section Manager se deschide. 

2. Poziționarea și Activarea: 

o Utilizați Section Manager sau Placement Manipulator (dacă este activat) pentru a 

poziționa și redimensiona volumul în jurul zonei de interes. 

o În Section Manager, faceți clic pe Activate Section (Activează Secțiunea). 

3. Moduri de Secționare: 

o Clip Outside: Alegeți Tools → Sections → Clip Outside. 

▪ Rezultat: Geometria din afara volumului devine invizibilă, permițând 

vizualizarea detaliată a obiectelor din interior. 
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o Clip Inside: Alegeți Tools → Sections → Clip Inside. 

▪ Rezultat: Geometria din interiorul volumului devine invizibilă, fiind util 

pentru a vedea ce se află în spatele cutiei. 

 

Workflow: Scalarea și Modificarea Formei 
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1. Scalarea Interactivă: 

o În dialogul Section Manager, bifați Scaling (Scalare) în secțiunea Graphic 

Manipulation. 

o În Graphic Viewer, utilizați manipulatorii galbeni (manipulatorii de scalare) de pe 

colțurile volumului pentru a modifica interactiv dimensiunea acestuia. 

o Debifați Scaling când ați terminat. 

2. Modificarea Formei (Shape): 

o În Section Manager, bifați Shape (Formă). 

o Selectați o muchie a volumului (aceasta se va evidenția în albastru). 

o Trageți muchia pentru a schimba forma volumetrică a secțiunii (Ex: din prismă în 

formă neregulată). 

o Debifați Shape. 
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3. Finalizarea: 

o Închideți dialogul Section Manager. 

Section Volumes completează instrumentarul de secționare, oferind o metodă flexibilă de a izola 

vizual o zonă 3D de interes. Aceasta este o tehnică avansată de inspecție, superioară unui simplu plan 

de secțiune atunci când analiza este localizată. 

 

5.9.ÎNREGISTRAREA SIMULĂRILOR PROCESS SIMULATE ÎN FIȘIERE .AVI 

 

Înregistrarea simulărilor este vitală pentru documentarea dinamică a proceselor, reviziile de design și 

arhivare. Process Simulate oferă opțiunea de a exporta secvențele în fișiere video standard (AVI) și 

de a genera vizualizări interactive bazate pe web (3D HTML). 

 

5.9.1.  Exportul unei Simulări într-un Fișier .AVI și HTML 

Obiectiv: Capturarea unei secvențe de simulare într-un fișier video și generarea unei vizualizări 3D 

interactive pentru web. 

Workflow: Înregistrarea Fișierului .AVI 

1. Setarea Operației Curente: 

o În Operation Tree, executați Click-dreapta pe operația simulative dorită (Ex: o 

operație robotică sau de flux) și alegeți Set Current Operation (Setează Operația 

Curentă). 

2. Deschiderea AVI Recorder: 

o Alegeți File → Outputs → AVI Recorder. 
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3. Configurarea Opțiunilor Video: 

o În dialogul Save Video File As (Salvează Fișier Video Ca): 

▪ Pentru Frame size (Dimensiune Cadru), alegeți Percentage of Window 

(Procentaj din Fereastră) și setați la 100%. 

▪ Avertisment: Evitați dimensiunea fixă implicită (Ex: 720x576), deoarece 

poate tăia părți din ecran. 

▪ (Opțional) Faceți clic pe Change (Schimbă) sub Compression (Compresie) 

pentru a alege un codec video (Ex: Uncompressed pentru calitate maximă, dar 

dimensiune mare, sau un codec Microsoft pentru dimensiune mai mică). 
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4. Salvarea și Pornirea Înregistrării: 

o Navigați la directorul de ieșire (Ex: Desktop). 

o Tastați un nume de fișier (Ex: my_video.avi). 

o Faceți clic pe Save. 

o Rezultat: Apare o bară de instrumente AVI (Recorder). 

5. Capturarea Secvenței: 

o În Sequence Editor, faceți clic pe Play Simulation Forward (Rulează Simulare 

Înainte). 

o Observație: Orice mișcare din Graphic Viewer (inclusiv mișcările mouse-ului, dacă 

sunt făcute) este înregistrată. 



Bazele simulării robotice și analiza cinematică în Process Simulate 

213 

 

 

6. Oprirea și Finalizarea: 

o Faceți clic pe pictograma Stop Recording (Oprește Înregistrarea). 

o Confirmați opțiunile de compresie. 

o Verificare: Rulați fișierul .avi salvat (Ex: pe Desktop) cu playerul video implicit al 

sistemului. 

 

Workflow: Crearea Fișierului 3D HTML (Export to Web) 

1. Pregătirea Vizualizării: 

o Ascundeți (Blank) toate obiectele pe care nu doriți să le includeți în exportul web. 

2. Activarea Exportului Web: 

o Alegeți File → Import/Export → Export to Web. 

3. Configurarea Exportului: 

o Navigați la directorul de salvare și introduceți un nume de fișier (Ex: 

Simulare_Web.html). 

o Pentru Level of details (Nivel de Detaliu), selectați o opțiune (Ex: Medium). 

o Bifați Include simulation (Include Simulare). 

o Pentru Operation (Operație), selectați operația simulative pe care doriți să o includeți 

în fișierul web (Ex: o operație robotică sau de flux). 

o Faceți clic pe OK. 
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4. Vizualizarea pe Web: 

o Deschideți fișierul .html generat în browserul web. 

o Observație: Vizualizarea web Process Simulate permite utilizatorilor să rotească 

(buton stânga), să facă zoom (buton mijloc) și să panneze (buton dreapta) scena 3D, 

și să ruleze simularea apăsând Play . 

Funcțiile de export oferă modalități complete de a disemina rezultatele simulării. Exportul .AVI este 

ideal pentru prezentări și editare video, în timp ce exportul 3D HTML este de neprețuit pentru 

partajarea modelelor interactive cu părțile interesate care nu dețin licență Process Simulate. 
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